Mac Cubase accept incoming network connections?

Looking for a way to eliminate the firewall message every time cubase starts. Anyone suscuessfully gotten rid of this on the mac?

It should go away after clicking allow or try adding cubase in the firewall application.

It does not go away, been doing this for a year. It has been added into the accept list and still persists to ask everytime.

Same thing here…doesn’t go away even after verifying the firewall settings and allowing the app. I came across a thread addressing this a while back which required deleting certain system files but the results varied among users. It didn’t seem worth the risk.

Hello,

May have been my thread > http://www.steinberg.net/forums/viewtopic.php?f=181&t=58232. As it turns out, my prescribed fix doesn’t work. Well it does, but it works by disabling the firewall. So, if you don’t mind having your firewall disabled, do that. You won’t get the prompt. Otherwise, you’re stuck. For me, it seems to only happen when loading a project with Omnisphere. Otherwise I’m fine.

I definitely agree about it being irritating.

Hi,

Not all mac programs are subjected to this behavior, in fact cubase is the only software that keeps asking for me. Ive read a few threads saying this line command works for other software, but I haven’t tried for cubase. Wanted to see anyone had a solution.

sudo codesign --force --sign - /Applications/Cubase.app/

I havent dared trying this though. I do have to keep the firewall up so thats not an option at this time. Hope we can get an official sollution.

Tried it - says no such file or directory. Cubase is listed as “Cubase 7.5.app”. I don’t know how to reconcile that in Terminal. I’ve tried replacing the space with an underscore, omitting it, omitting the decimal between 7 and 5, but I can’t get it to take. Any ideas?

I always renamed my Cubase 7.5.app to Cubase.app as I got rid of previous versions on an install.

Its really strange why cubase prefers to constantly need you re accept the connections while nothing else on my mac machines does not. Maybe we can get some sort of official word or fix?

So have you tried renaming Cubase back to Cubase 7.5.app? Does the problem persist?

Switched the name. Didn’t work. Still got the prompt. But again I believe in my case it’s associated with my projects that contain Omnisphere.
connection.png

The name has nothing to do with it unfortunately. Its been like this since I’ve been with cubase regardless of the name of the app, and has been the only program on my mac to keep up with the firewall annoyance message for years now. This isn’t a normal behavior on OS X, and now has been a problem since Lion, Mavericks and now Yosemite.

Their has to be a better solution to this, steinberg?

Sorry I wasn’t clear. I tried the sudo command line you’d suggested above and it didn’t fix the issue.

You’re correct, I had no problems until the introduction of the hub in Cubase. Of course you’d think disabling would fix it but it doesn’t. The message only appears the first time I launch Cubase for the day after booting the Mac; subsequent launches don’t render the message. I’ve tried contacting Steinberg directly but have discovered you’re more likely to find a leprechaun’s pot of gold before getting any response other than “reinstall the software chump”. I’m also not running Omnisphere.

I found a forum about this issue, link:

http://superuser.com/questions/100013/why-does-the-mac-os-x-firewall-dialog-recurringly-pop-up-and-disappear-by-itself

Good luck :slight_smile:

I think I found a solution to this at least for those using Cubase IC Pro. I just bought a new computer and was enjoying the clean installation of 7.5.3 not showing this network message until I installed the SKI Remote device to enable the IC Pro application. Once I did that, the Incoming Network Connection message appeared the next time I opened Cubase. Once I disabled the SKI Remote device, the message no longer displays. I had the SKI Remote device active on my previous setup as well so I simply overlooked this as a cause. And, regardless of having Cubase approved for network connections in the OS, as long as SKI is enabled, the message appears upon opening.

I have the same problem with 8.5 does anyone know if this has been solved?

I have the same problem, noticed it started after I installed Lexicon PCM bundle, and it pops up as soon as I open an instance from that bundle.

same issue cubase 10, any ideas?

Late to the party, but I managed to fix it by deleting the SKI Remote (haven’t found myself using it for a while, let’s see if I miss it…)
On a Mac: Mac HD → Library → Application Support → Steinberg → Components