Mac OS - Bad pdf resolution for the score (sheet music)

Hello all!
If I want export score (sheet music I created with score editor) in pdf format on Cubase 10 pro on macOS there are two way:

  1. File–>Export–>Scores and choose “pdf”
  2. File–>Print–>Save as pdf
    Both files have really bad resolution quality! (and the one with the first method has just one page!)
    Bad quality I mean bold lines on the music staff, rough musical notes, and so on…
    How can I obtain best quality pdf score?
    Thank you all and sorry for my english!


  1. Can you upload the pdf so I can better understand?

  2. The Export function is meant for exporting a single page or portion of a page to an image file for inserting into another document, as from MS Word or Apple Pages. It has settings to change dpi, see the linked page:

Thank you!
Of course!
The firs file is what I think it’s a good pdf quality, to print or to share sheet music. I did it many years ago, and I don’t know how (always on cubase!)

The second one is what now I get if I click on Save as Pdf in the print page. I’ve tried all the possible configurations in that page but the result is always this. And for me it’s a bad result, in my opinion!

Thank you again for your help! :slight_smile:

In this screenshot I put the quality I would get on the image on the left and the quality actually I have on the right side.

Do you have access to another PDF print driver in order to to eliminate the Apple pdf driver as the culprit?

I have an HP printer installed, but I can install something more if it could be useful (do exist other pdf drivers, apart from apple?).

I downloaded and installed a free notation software yesterday, to try to understand where the problem is. It’s called Musescore. I don’t like it, but its pdf files are really good, always using File->Print->Save as pdf.

Really strange!!

Nobody can help me?

My problem is that since I’m not on Mac, I can’t test this- I’m hoping a Mac user will chime in.

I did observe that the file looks correct when opened in the Google Drive Viewer, but not in Adobe pdf reader.

Also- is it possible that editing the value in Score Settings>Project>Spacings>Line Width System Lines helps?

It might just be how the .pdf is being displayed. On my desktop mac I notice .pdf’s being blurry, but the same ones on my macbook pro are fine.

Don’t worry lucatron.
Actually, ironically, “what you have” is better quality than “what you want”.
It’s just a display issue. :wink:

The reason is that the file you think is good quality is an image, and the one you think is bad is actually vector, thus the display difference between the two, depending on the viewer.

Thank you all guys!
-steve-, yes, that setting helps very much! it increases a lot the final result, if I decrease the width line! Thank you very much!
TheMaestro, I too had thought it was an image, because it is 4,6 mb vs 500kb. But…how it’s possible? the “good” pdf was done with the same method (file>print>save as pdf) of the “bad” vector one! How can we get one or the other?
And therefore the final question is: how improve the quality pdf are being displayed!

You’re answering yourself your question in your first post. There are 2 methods and -steve- explained the difference.
Here on PC I don’t even have PDF as an option for the first process. (maybe a Mac thing!)
The PDF created with the first method is likely an image converted to PDF format, and the second method creates a real PDF.

How do you view your files: what is your PDF viewer?

I view my files om “Preview”, a macOs app to see (and edit) jpeg, pdf, and other files!
Yes, the first process creates a “non vector” pdf file, an image converted in pdf, as you say. But it creates just one page at a time. The file “what I want” was created in 2013, with Cubase 7.5. It created a pdf/image with all the pages. Maybe this function doesn’t exist anymore on newer versions!

So what is the problem?
The second method is the one that should be used anyway: “File>Print>Save as PDF” which produces the best results, and you get all the pages.

Try Acrobat Reader for viewing to see if you get a better display.

It looks as if Cubase 10 creates a vector PDF, as TheMaestro has noted, rather than the bitmap PDF of Cubase 7.5. A vector PDF is preferable though it is clearly rendered differently to Cubase 7.5 and to what you want.

Cubase’s score editor works, but it is not going to match the engraving quality of specialist notation and engraving software such as MuseScore. I suspect you would get even better results than MuseScore if you exported the data as MusicXML to Steinberg’s Dorico but that is, of course, not free software.

This thread is not about the relative quality of Cubase compared to other programs, and the OP has not requested suggestions about a software alternative. Kindly refrain from hijacking threads.

Thank you very much!
Changing some settings the vector pdf can have a better displayed quality, looking for the best compromise for the various software and computers. Maybe the bitmap pdf have better “feeling”, ready to go, (the icons on the desktop too are different, as in the attached image), but on the other hand they weigh much more then vector ones.
Maybe improving the “Export” function can solve this, giving more options to the users.
Thanks again,

I think you’re doing things backwards.

Again, the score you get doing “File–>Print–>Save as pdf” is perfect.

In my opinion You should not change your settings in Score Editor to get better results for display on computer only, because as you know it will be differently displayed depending on the viewer used.
Besides, I don’t know what is the final goal of your score, but doing so, you would get unwanted results when you’d want to print it.

The only viewer that should be considered as a reference is Adobe Acrobat.
That brings us back to the most important post of this thread:

Please view your score in Acrobat and make sure you change the settings in Acrobat as follows:
Edit>Preferences>Page Display then in Rendering section, uncheck “Enhance thin lines”.

For “Preview” on Mac, try to find if there is any similar setting.

If you still want to go for bitmap images in PDF, you should try this:
1- Export your entire score in PDF with “File–>Print–>Save as pdf” from Score Editor
2- In Preview export all pages to images (PNG)
3- in Preview convert all exported PNG back to PDF

Finally, regarding your icons display issue, I believe you should contact Apple :wink:

Hope this helps.

Ahah. Thanks. In Foxit PDF reader that pref is called “Smooth line art” (I used Adobe reader as the example since it’s better-known on Mac)

My eyes did not deceive me, fortunately. :wink: It was the lines that looked bad, the rest of the printout looked fine.