Mac OS10.14.6

My computer os can not be updated any higher than OS 10.14.6
Does Cubase 12 really not support this?

Downloaded the installer for 12, but while trying to open it, Mojave warns you that you need to update the OS in order to use C12.
It seems it really won’t work on 10.14.6. Sorry about that.
If anyone had a difference experience, even if not officially supported, I’d love to hear the details. :slight_smile: