Macbook Pro/Magic Mouse & Cubase 10 Pro

I am dying here, folks, please tell me someone else has shared my issue!

When I use the magic mouse with Cubase it jumps around like it has a ind of it’s own. I have tried to research this and have seen a lot of suggestions ranging from ‘stop using magic mouse’…which I don’t think I should have to do…to 'change the settings in preferences on the MAc…but this issue only exists when using Cubase. Someone else having this issue and if so…please, please, please, is there a solution?

Thanks, folks!