Macbook Pro Wavelab 9.5 Can't Assign Outputs with Built In Audio Anymore


Using Wavelab 9.5 on 2019 Macbook Pro i7 Big Sur v 11.5.2, I’ve lost the ability to correctly recognize the Built In Audio in the Audio Connections preferences.

It was working properly but now I only have “Channel 1” available in the outputs selection for the Built In Audio (as you can see, only “1” is available when I try to select the output for channel 2).

Another device (Dragonfly) works ok, it’s only the Built In Audio that’s not right anymore.

This only happens in Wavelab so far. Doesn’t happen in Garage Band. Built in Audio is fine there.

Tried trashing Wavelab Pro 9.5 prefs. No change. Tried clean install of Wavelab Elements 9.5, but it has the same problem.

I can’t restore the computer successfully to an earlier backup to try to resolve this.

Thank you.

p.s. things I’ve tried without success: Deleted 3 audio related plist files in the library folders. Reset Core Audio in Terminal. Reset NVRAM. No change.

This was solved in WaveLab 10. But in fact, if I remember right, this is not a “real bug”. The second entry, the missing “2”, is just invisible in the menu, but you can still select it.

Thanks so much PG. That works. Sorry if I missed finding discussion on this.

Just for the record, when I say the Dragonfly works ok, I mean it works “normally” with Wavelab 9.5 if you add it to an Aggregate Device. Without the Aggregate Device the Dragonfly doesn’t switch sampling rate automatically when switching between montages of different rates. My experience anyway.