Mackie Control switch by channel doesn't work

Hi people,

In Nuendo 12 on my QCON pro G2 (Mackie Control) I can switch track 8 by 8, but not 1 by 1 like in previous versions of Nuendo…

Nuendo 12 - Mackie control

Does anyone have this problem ? Did Steinberg changed Mackie protocol implementation ?


A solution is to hold Shift + « 8 » banking button to switch one by one. But less practical than just press one button like before.

I use Mackie Control with N12 on a SSL Nucleus and those features are still working fine. My only thought would be to go to the Studio drop down menu —>More Options—>Mackie Control and Mackie Control 2 and make sure they are set to Compatibility and not Cubase.

Compatibility does the trick with using icon