MACKIE CONTROL WITH 2 MASCHINE JAM units

cubase seems to have issues using mackie control , i managed to get 2 units working for the setup once then reloaded , the units didnt connect , this doesnt happen with my other daws , i can use one unit for 8 tracks but the other unit will have no control with other tracks and the first unit only controls eight tracks also deleteing the mackie control at times crashes Cubase 9.5

osx 10.12.6
64 gig ram
6 core mac pro
running on 4 screens
controllers Maschine studio, 2 maschine jams, novation impluse 61 , kawai vpc1 , motu 896 mk3 . midi M-audio midisport

I use Mackie Control with the X-Touch and it works fine with 9.3 & 9.5.

i had the bcf2000’s and worked jams may need its own coding

i can use cubase with one unit and 8 tracks for the jazz tunes its enough , but use another daw for more track soundscores , at this point its my only option the jam sweet hardware

There’s a few buttons on X-Touch that are mislabeled to what they actually do in Mackie mode so I’m in the process of remapping a generic remote protocol so it will do exactly what I need. Very time consuming but worth it in the end.

i did try that still same issue very odd maybe in future updates i can stay cubase for all projects Reaper and DP9 have no issues for me after customizing them but i’ve been with Cubase from version 4

just tried something for some reason clears issues loading , i reinstalled version 8.5, setup a project with my controllers in reverse order in other words unit 2 controls 9 to 16 tracks that became mackie control the other became mackie control 2 , reset both, now units working , then went back to 9.5 and setup the units with different project , units now working , i’ll see in the AM when i reboot if all is ok

UPDATE its a 9.5 issue i tried multiple times on 8.5 and then on 9.5 , 8.5 loads fine,
in 9.5 when you do anything creating new tracks or changing the controller is no longer available in 9.5

version 9 also AN ISSUE

I’d been having programming problems using generic remote in 9.5. Maybe I should try version 5 and see if I have success.

yes something is not right here , at times deleting mackie crashes , i cant get generic to connect and it does see the controllers so the issue is the output

My problem appears to be the hardware. Cubase 5 acted like 9.5 so the software is not at fault in my case. Behringer confirmed.

found somethng interesting with me its maschine jam units , mackie looses connection or cant cascade and cubase crashes at times doing this

my solution create a mackie device and leave it blank the create 2nd mackie device add hardware and add 3rd mackie add the other device this solved my problems now i’m able to use my jams as mackie with no issue (so far)

Glad you got that worked out. My problem needs a firmware update from Behringer. You seemed to have gotten yours corrected in house. That’s good!