Mackie MCU Pro randomly not working

Hi all,

I’m trying to connect my Macke MCU Pro and another custom made midi fader device with Nuendo 11. This does work sometimes, but most of the times it doesn’t. The Mackie and the other device are in perfect condition and my PC recognizes both devices. Sometimes when I reset the Mackie, it magically works. Other times, nothing happens (the Mackie starts, but it doesn’t connect to the project or Nuendo).

For both devices: On some occasions eveything works perfectly, but most of the times it doesn’t. It seems very randomly. I tried saving all settings when eveything works. But a day later, when my computer is restarted, the devices no longer work (while the settings are still the same).

For the Mackie: I can select the Mackie in the Studio Setup. I have the Mackie Control protocol selected on the MCU Pro and I selected Cubase in the Mackie options box.

I have a feeling the issue is with Nuendo, because there seems to be nothing wrong with the Mackie and the custom made midi fader device so it looks like the issue is within Nuendo (or with my settings).

Is anybody facing the same issues? And if so, is there a solution?

Thanks in advance, cheers. Toon

Hi Toon,

Does this behavior also happen with any other software you use this hardware with?
Are the drivers correct for your system?
Are your MIDI cables good, clean connections? Dusty?

Hi, thanks for your reply!

Unfortunately, I don’t have any other software to test the Mackie with. But I know I had the same issues with Cubase 8.5 and Nuendo 10. I’ve checked the drivers and those are fine and all updated.

I’ve order a new MIDI cable, maybe that’s the issue. But the weird thing is that Nuendo recognizes the Mackie, it knows it’s pluggid in. But sometimes I just can’t get it to ‘connect’ with my project (while all parameters are good).

Hopefully the new cables will fix things.


1 Like


the issue seemed like it was fixed when you used teamviewer. But as soon as I restarted the computer the issue was back. So I gave up on my Mackie, apparently I can not use a midi controller normally with Nuendo.
But now the issue is worse - my midi keyboard randomly stops working. everything seems fine, the keyboard works on another computer. Could you see what the issue is, maybe with teamviewer? The midi integration is very unstable with Nuendo and it’s driving me crazy. The issue must lie within Nuendo because it’s all my midi hardware which isn’t working.

I need a quick solution because I can not work now.
Hopefully you can help me.
Thanks, Toon

Teamviewer? Not sure what that is. I have only responded to you here, and have not helped you personally. Maybe this reply was meant for someone else? Cheers. Hope you find the issue.

Wow, this was meant for Steinberg support. Must have replied to the wrong mail.

Sorry, and thank you!
Cheers, Toon

1 Like

No problem. Cheers!