Mackie via midi on a Motu 828mk2

I’ve just had a MBP die on me and bought a replacement, and am running 5.5 successfully on the fabulous new 2.7GHz quad.
While sorting this out I had to revert to using my Mac Air. All was basically fine with the exception of controlling my Mackie MCU via midi which I usually do off the midi sockets on my 828mk2. Initially I hadn’t got a Thunderbolt to firewire lead so couldn’t connect to the 828 at all. I had, however got a simple usb to midi lead, but nothing I could do could make the Air control the MCU.
Today I had a usb e-licence issue (now resolved) with the new MBP which meant I had to go back to the Air. This time I had the Thunderbolt to Firewire lead. All the audio found it’s way out to the Motu with the odd vst setting changed but I still couldn’t get the Mackie going. I removed it and added it again and the 828 midi ports were still not visible.
The only thing I can think of is somewhere I’ve seen that Protools stuff can upset it (which the new MBP doesn’t have on it, but the old one did, which all worked perfectly). It’s pt8 that I have installed which I have to use with one of those (useless) MBox Mini’s.
Any thoughts?
Thanks, Rob.

By the way, just to add to that, when booting up it stays for ages on the Searching For Core Midi page. Then it says, “Can’t connect to core midi. You have to restart your system”, and when I click OK, it then finally opens the programme. Must take over 5 minutes to get there. Updating to 5.5.5 doesn’t help either.