MacOS Catalina

Has anyone here had a success installing Steinberg products on MacOS Catalina?

I tried this last night and the SDA doesn’t run. Maybe a direct download without SDA will work but I don’t know where to get that.

Just installed Catalina on an external ssd for testing.
Cubase runs, download assistant runs but have to give it permissions which is kinda annoying.
My steinberg ur28m doesn’t work though. It did when I rebooted but suddenly disappeared and even a power cycle won’t get it back.
My Axe fx is also not visible like it’s not connected.
I would avoid Catalina at all costs but if you do try it do it like I did by getting yourself an external drive.

I’ve put Catalina on one of our Macs and so far I have found it much more troublesome than the betas of High Sierra or Mojave. I haven’t even tried installing or running Cubase, there are so many problems with for example network permissions, installations, social media, the list goes on…


Thats free app runs a scan on your system to tell you where you problems are.
Steinberg Download Assistant flags up but only the uninstaller (so maybe the installer too?)

"Uninstall Steinberg Download Assistant is a 64-bit app with some internal components that are still 32-bit.

It may or may not run correctly on macOS 10.15, depending on how the app handles situations where its 32-bit components would normally be used. Check for a more recent version or contact the application’s developer for more information."

There a lot of worrying stuff in the list like some iZotope parts and a few legacy things from Native Instruments,Guitar Pro among others.

I’ve installed Catalina beta too - but nothing worked, Catalina complained about unsupported version of Steinberg software. Also the Licenser from Cubase refused to run. So I restored Mojave from backup… Not encouraging so far.

I’ve upgraded to Catalina and at first I wasn’t able to run my two instances of Cubase Elements (vers 8 and 9). For some reason, I tried opening ver 8 again while holding down the Shift key. There were a number of prompts for some apps to access parts of my system, such as my Document folder and external SSD, and then voila, it opened and appeared to work just fine. I’ve held on to version 8 so that I could continue running 32-bit VSTs. I then opened 9 the same way and answered similar prompts and it opened and appeared to work just fine. I happed to have loaded a project that ran several 32-bit VSTs and to my surprise, they actually ran fine. I opened the Add Instrument dialog from within version 9 and could view all of my 32- and 64-bit VSTs.

I’m still not sure why this worked out, but I hope this helps someone.

UPDATE: The Steinberg ASO driver isn’t very stable and drops its connection infrequently.

“We will provide further information on compatibility with Catalina by the end of October.”

Not long to go now, Steinberg. My currently non functioning Ur-12 audio interface with MacOS Catalina awaits with great interest.

I upgraded to Catalina and although I’m able to record audio without any issues importing audio crashes cubase. I’m running Pro 9 with an Apogee Duet. It’s a major headache, importing WAVs is a big part of my workflow. Also heads up to anyone who has Waves plugins, version 9 plugins wont work and the only support you’ll get from Waves is them telling you to pay money to upgrade to V11

Fingers crossed - Cubase 10 loaded and working really well, as is Wavelab. I can’t get Halion or Groove Agent to work (I was half hoping that today’s 6.3.1 Halion update would make it Catalina compatible), but astonishingly, for those who use Jamstix - Ralph has got it working under Catalina already!


Actually I can not use the Mac Operating system because I think it is very critical for me

I got a new laptop in September and upgraded to Catalina right away and I haven’t been able to use my UR22mkII since. I installed the new driver but the USB light flashes on the device and it isn’t recognized in my Audio setup or Garage Band. It gets recognized as soon as I uninstall it but it doesn’t work properly. I’m planning on upgrading to Logic Pro X but I’m holding off until I can get this to work.

Have you upgraded your eLicencer? It all started working for me with the UR824 once I had installed the newest eLicencer (in fact I think I re-installed it again after upgrading the new Yamaha USB driver).


I’m not sure what the eLicencer would do, I don’t use Cubase. My problem is that as soon I install the new Yamaha Steinberg USB Driver, it doesn’t recognize my UR22mkII anymore. So, I notice that there’s a new Firmware update but it can’t see my device with the USB driver installed. When I uninstall the driver, it recognizes the unit but then the firmware asks for the Steingberg USB driver. I updated the elicenser just in case, but it didn’t do anything.

ur242 audio interface not recognised by Ableton 10 running on catalina