MacOS Mojave and UR22

Hello all,

I’ve used UR22 with no problem for a couple of years, but I recently updated to Mojave and now it stopped working.

Garageband recognizes it, when I plug it in (as in I go to settings, and then sound/midi, I can see it, and it says 1 midi unit is detected).
It does not see or recognize any sound going through though.

So I wonder, is this just a driver issue, and I’ll have to wait, or is it something else?

Thanks
Jacob

I have a similar problem as well, and am hoping Steinberg will have an official response ASAP.

Best
Adrian

Jacob

https://www.steinberg.net/en/support/downloads_hardware/yamaha_steinberg_usb_driver.html

Hope this helps

Just confirming I’m using the latest drivers and firmware, and I’m also experiencing no Midi input using Logic X on Mojave.

Thanks guys, we probably just have to be patient then. :slight_smile:

Same here. Do you guys know when this problem is going to get fixed by Steinberg? They are sayin in november right?

Yeah, that’s what I saw in an article, no later than november. Still a long month though,huh.

Really hope they update these drivers soon… Had confirmation from Ableton support today that Live 10 is fully working on Mojave (with update to follow shortly) and really want to get updated!

So this happened to me too, then I just checked in and downloaded what seemed to be the new USB driver (it says 10.14 which is Mojave, I believe). Then, I plugged in all the stuff, and still no sound. I believe I’ve followed all of the instructions, but I’m going to try it all again. If anyone is having this same problem, I’d love to know.

I also just got the new drivers, happy as can be, and the shit still doesn’t work. So if anyone have a solution, please let us know. Meanwhile, I’ll see if I can fix it, but is any mods or developers browsing these forums to see what problems might pop up, or do we need to raise a ticket?

EDIT: When I check the Sound in mac control panel, it sees UR22, and also sees that I play on my bass (as in, the sound goes up and down), but Garageband won’t recognize it. That is really weird, as the computer is recognizing it.

But it doesn’t have a “control options” and the microphone has, and in effect, in Audio midi control panel, the volume panels are disabled.

EDIT: FIXED!

So I don’t know why, but in the Security and Privacy (in the control panel, just use spotlight), I went to the privacy tap (make sure your garageband or whatever tool is closed), and under Microphone, Garageband was disallowed to use it. I enabled it, and it started working.

Hope this solves it.

I have installed the driver for my Steinberg UR22 and Mojave. I am using studioOne as my DAW.

I am experiencing in terms of problems is that after about three minutes of recording the StudioOne momentarily stops recording and any fx on the channel drop out and then after a few seconds all resumes working.

It’s not appear to be an issue with CPU as I do not detect a drop in the CPU via the CPU processing window in the daw.

Thoughts?

Working great for me.

Try turning your wifi off, and try again.

Hi!

I am very late with this so lots of you might already have had this resolved. But just in case some one drops in at this point I thought I’d share how this got resolved on my end.

[FIXED!]

As JacobGp did I also turned to the Security & Privacy. But instead of finding the block under the Privacy- tab there was a block at the lower part of the sections main page. The same thing you get when you install the driver (for high Sierra or Mojave) had reappeared. All I had to do was unlock the padlock with my admin password and hit “allow” and my Steinberg UR22 mk II was back in line. I hope this can clear things up for some of you reading this.

regards / Joan

alderman_swe - THANK YOU! that worked for me. The “block” was also discretely noted in the main page.

Where can I find this block?

dude. THANK YOU!! Thank you for the save, 2 and a bit hours gone downloading and installing and uninstalling until I read this went and went in privacy settings! I was wondering my CI2 was lighting up but not doing anything and why logic was recognising it. Went into privacy settings and found that the app wasn’t allowed. Thanks a million!

I downloaded the new driver, updated my mac to mojave and now my mac will not detect my UR22 driver. at all. no matter what I seem to do.

I just don’t know what to do to make it work?