Macro function disappearing after restart

Hi,

I am using Cubase Pro 10.5.12 Build 123 running on Windows 10 and I created a macro that works perfectly until I restart Cubase. After every restart the highlighted function on the left side of the picture below disappears from the macro.

I can recreate this simply by adding a new macro with just a single “Process Plug-in” Function. The macro will still be shown in Cubase, yet the process is missing after restarting Cubase.

It doesn’t matter what VST plugin I am using, so far I tried several VST 2.4 and VST 3.0.2 plugins all with the same result.

So far I created a new profile, I erased my %AppData%/Steinberg/Cubase10.5_64 folder, I monitored the “Key Commands.xml” file, unfortunately with no success.

To my surprise after restarting Cubase, the “Process Plug-in” function remains inside the “Key Commands.xml” file under my macro function, as a matter of fact, the file does not change at all after. The unique identifier inside the string “Name” does not change unless I choose a different VST plug-in. So my suspicion that this ID could change after every restart was false. Now I’m not sure what to look for next.

I hope, it’s not a bug and somebody can help or guide me in the right direction.

All best,
Mark

Hi,

What does the Macro do, please? What are the steps?

Hi,
are you not able to see the screenshots I provided? They are right from the macro editor inside cubase.

The Macro does a reverse effect. Reverse, then apply VST Effect, then reverse the newly bounced version.

You can recreate this issue yourself by simply creating a new macro and adding just one function : Process Plug-In (use any VST Plugin, it doesn’t matter which one)
Then restart cubase and you’ll see that it disappears. I just don’t understand why.

Thanks for your reply!

Feels like a bug. There is so much information in your report it’s difficult to parse. Note that English is not the first language of every user here.

Is the report simply: “macros with command Process Plug-in break after a quit and restart of Cubase”?

If so, I can confirm.

Repro

New empty project
Create macro with Process Plug-in as its only command.
Quit Cubase
Launch Cubase
Observe command is now missing from macro.

Follow these guidelines in the future for bug reporting, if at all possible.

https://www.steinberg.net/forums/viewtopic.php?f=286&t=188766

Edit: reported to Steinberg

Thank you very much, Steve.

I will consider writing a bug report, though I’d never done one.

I am new to forums and I am sorry for not being aware about my post being too densely packet. I was struggling for so long with this issue that I might’ve been a bit over-eager in explaining all my efforts. I really didn’t want this to be a bug, because - so far - every issue I’d had with Cubase in the past was due to the fact that I was simply using it wrong. My long explanation probably also was trying too hard because I didn’t want to be looked upon as a fool who just “didn’t click that box right there”… so to speak.

You posted while I was editing my previous post…

Totally understand where you are coming from, and hope my response didn’t feel harsh- just brief!

Thanks for making the report, I was able to get it added to the database.

Hi,

Sorry, what is the purpose of this Macro, if the only one step is to process the plug-in, please?

The purpose is to confirm that it is a bug. If several users can reproduce this behaviour, we would be able to create a bug report so that this could potentially be fixed in a future update of Cubase, to make it even better than already is.

Steve was kind enough to confirm that the macro breaks after a restart of cubase.
Hope, this helps.

Hi,

My question is, does the bug appear in a real scenario (which makes sense)? Doe sit appear if there are other steps in the Macro (what is Macro made for)? Does it appear, if you add 2 Direct Offline Processes to the Macro (then it’s a real scenario)?

I’m not questioning, this is a bug. I’m just asking, how serious it is.

Thanks

CAN-29315

My question is, does the bug appear in a real scenario (which makes sense)? Doe sit appear if there are other steps in the Macro (what is Macro made for)?

Unless I’m misinterpreting, the original post answers these questions, including screenshots of a multi-step macro.

Regards,
Dave

Thank you very much Dave,

To me, this macro is a game changer. When creating reverse reverb effects, that saves me tons and tons of work. Exactly what a macro is intended for.

I must admit, Martin’s question made me feel a little bit unwelcome.

All best,
Mark

Please allow for polyglot skill differences - I know Martin for being polite and respectful at all times, and tone is difficult to interpret in text.

Hi,

If this is the only one step in the Macro, there is a workaround for you. You can assign Key Command and trigger the only one process this way (so you don’t need the Macro then). If it crashes even in all other cases (independent how many commands are around), then I can’t see any workaround, I’m sorry.

And of course the relevance of the bug is different in every of the cases.

It’s not the only command, the rest of the commands are in the OP.

I’m beginning to feel sorry for starting such a mess in here.

@Martin: Thank you very much for trying your best to help me out with my problem. But unfortunately we are talking at cross-purposes - we seem to have different levels of what we are trying to communicate.

My intention in the OP (original post) was to be as specific as humanly possible. And the problem with complexity is, one could easily misunderstand what was initially simply well meant.

Once again thank you everybody - especially -steve- - for helping me with my problem but also learning so much about how to use forums and life.

All best,
Mark