Macro (start-record-insert midi cc value-stop): why does it record behind the cursor position


Hello, I have a macro using bome midi translator doing the following :

Start
Record
insert cc1 with a certain value
stop

but why does the value register “behind” the cursor position ?

Hi,

What do you mean?

I can see the cursor is behind (on the right side of) the MIDI CC, you inserted.

Btw, do you use any Delay or Wait, or something like this in your Macro?

Where was the cursor when you triggered the macro?

image

yes there is some delay, very minimal, but it doesn’t make sens that the midi point is inserted behind the playhead cursor (which is at bar 22 in the image)
@mlib the playhead cursor was at bar 22

Is the result always the same? Are you using WinRT MIDI?

always exactly the same.

What is WinRT MIDI ? I have seen this name before …

Can you post screenshots of these 2 Preferences Tabs

Try this. Put 2 Rulers in the Project, one each Bars & Beats, and Minutes & Seconds. Then run the Macro several times at different Tempos.

If the cc is always a constant amount early, testing it at different Tempos lets you figure out if it is off by a fixed amount in MIDI Ticks or milliseconds.

EDIT
Also try it with the Track set to Musical Timebase and also Linear Timebase.

tempo 150

tempo 70


I found a more elegant macro using retrospective record so everything is instant.

1 Clear retrospective buffers
2 Dump the midi CC value from bome midi translator
3 insert retrospective record

it works great

Glad you found a solution.

From your pix it looks like the offset is constant in time & not beats. So I’d guess it’s related to latency in some way.

1 Like

in fact, even using retrospective record, I am getting latency issues, because the value is inserted behind or beyond the cursor playhead.

Do you know how to insert the CC at exactly the playhead position using the logical preset. For now I could insert it at the position of the selected note