Macro with vst plugin not saving


I’m trying to make a small macro to send audio to IZotope RX 7 in Nuendo 10.3 (Windows 10 1903)

RX Send

  • Process Plug-in - RX 7 Connect
  • Direct offline Processing - Apply

Everything works ok.
I close nuendo, open it again and the command is not working.

I look for the macro in Key Commands and the Connect command is missing, so it looks like:

RX Send

  • Direct offline Processing - Apply

I tried using a different vst plugin for test and still the same, the plugin command dissapears from the macro.
Deleted preferences, new profile, same.

Can someone please reproduce this? I tried it on two different systems.

Thank you!

I did a bit more research, tried this in N7, N8, N10.2. Tried in N10.3 on a mac. It seems no nuendo version allows for a Process Plugin to be saved in a macro. The option is there, it works as long as I don’t close the program, but it’s not saved.

Is it by design? Then why am I even allowed to enter plugins in macros? The fact is that it would make a better RX workflow, just a keystroke to send and another one to apply and close the DOP window.

Sadly I have to redo the macro each time I open the program.

I would try low-level hacking :wink: of “Key Commands.xml” and find out if the macro typed right in that file is cleared by Nuendo restart. Maybe macro created outside of Nuendo doesn’t get cleared?

Thank you McSound.
Just checked Key Commands.xml
Nuendo actually writes the command in the xml file as soon as I click OK in the key commands window, but does not load it at startup.

This is the macro:

         <string name="Name" value="RX Send"/>
         <list name="Commands" type="list">
               <string name="Category" value="Process Plug-in"/>
               <string name="Name" value="5653545A6E374C5258203720436F6E6E"/>
               <string name="Category" value="Direct Offline Processing"/>
               <string name="Name" value="Apply"/>

Also I read somewhere that RX connect should be manually applied in Direct Offline. Auto-applying kind of doesn’t work. Maybe that’s the case. What about other plugins? Have you tried them with macros?

Working with RX Connect requires not using Auto-apply.
That is a workaround which is unavoidable, due to a violation of the VST3 protocol of the RX Connect plugin.


That is why I made the macro, to have “Auto Apply” disabled and to call “Apply” only when needed, after the plugin is invoked. Sort of “manual apply”.
I also tried with other plugins, they do not get saved in the macro.

I’ve just encountered the same issue! Editing “key commands.xml” doesn’t help. I noticed than this occures more often when I use macro in macro. Weird thing, some of my “folded” macro work fine, others just don’t want to be saved, no way. Even more, when I come back to make some changes to my macro I see that some lines are not on their places how I made them. :astonished:
Definitely it’s a bug! :frowning:

I’ve dropped a mail to Steinberg about the Plugin issue. Maybe it would help if you drop a line to them too. Although I don’t expect an answer soon, given the pandemics.
I used the email listed here:

I also checked the manual regarding macros (page 1257), It does not mention any limitation of using Plugins or nested macros.

So it is either a bug, or an mishandled exception of the way we should use macros.
It’s nice you can not nest a macro into itself :astonished: , so nesting macros were on their table! :nerd:

I’ve also noticed that if you run macro with a PLE command inside while PLE window is open, not only this PLE command fails to start but the whole macro system breaks and highly likely doesn’t work properly anymore. I had simple copy-paste that didn’t work inside macro after that. Restarting Nuendo didn’ help to initialize macro system, only after restarting Windows it worked as expected.

hi mufi.

i had the same issue with my rx declick.

i saved the plugin as a favorite in the dop window.
instead of using the process plugin itself for your macro use the shortcut for those fovorites.
choose the bank and the slot where you saved it.
you shouldn’t chnge the fovorites as it effects your macro.
i’m using bank 4 and always leave it as is.

after a restart of nuendo your macro should always work. mine does now :smiley:

Wow, thank you SloBurn66, it works!

Now it’s one key send, one key apply and close dop.
You saved me thousands of keystrokes!