Macros don't execute properly with remote

Macros do not execute properly when they’re triggered from a remote.

  1. setup a macro like: Select ref track> Close all folders> Select Woodwinds folder> toggle open close folder

  2. Trigger by keyboard shortcut “WORKS”

  3. Assign to remote and trigger “ONLY PARTIALLY WORKS”

Dear SteveInChicago please don’t move to miscellaneous. This issue has been documented before by other folks. Thanks.

OSX 10.9.5

Reply from support:

I am seeing some inconsistent behavior myself. I am going to do some further testing as well as contact development. I just wanted to keep you up to date on where i was at with your case.

If you have any questions, please let me know.

Thank you
Jeff Deno
Steinberg US Support

Same here. Have some macro’s which can’t be remotely triggered by CC. The macro’s seems to be related to Visibility. Luckily TouchOSC can send key strikes so thats my workaround. Seems to be more problems with macro’s like the order commands insert in an excisting macro, commands that disapear from a macro, etc. Not able to change the order of commands in a macro seems to be by design. Nice when you are building macro’s and have to start all over again when you need to tweak things to get it to work :cry:

Like a lot of Cubase features: They sound really handy but when you start using them they seem far from finished coding.

Regards,

Martijn

My workaround is sending MIDI to keyboard maestro from Lemur. Otherwise they still don’t work in Cubase 9