Macros Referencing Macros Not Working

I find it odd that Cubase allows me to have macros reference other macros and it works, the odd part being as soon as you close Cubendo and reopen the references to the other Macros have disappeared in the Macros. To be clear it is great that they work when the session is open when you make it but why it doesn’t persist when you open the application is a bit odd.

I spent a bit of time adding these in and confirmed they all worked and then saved my key command presets saved and closed only to find they no longer work on restart, sorry to be redundant.


It works to me here on macOS with Cubase 10.5.10.

So you have saved your macros that reference other Macros and then quit and reopened Cubase and they are all still there? It works as long as I leave Cubase open from when I create the Macros. I am on Cubase 10.5.10 as well and MacOS 10.13.6.


Yes, this is exactly what I did. Works even after Cubase restart to me here.

Well shoot, I am at a loss why it isn’t working for me. I reset my key commands and tried again with the same results. I’ll keep pecking at it.


After Cubase restart, can you see the Macros in the Key Commands.xml file?

It’s rather strange it does show up in the Key Commands.xml when I shut down Cubase. I changed the name in case something in the name was causing a problem. I had and ampersand “&” and changed those to and. I have tried simple names and they are in the file when I shut down and stay when I open Cubase back up and a project they are still there. I run the command and they are still in the .xml file but they don’t work on reboot. As soon as I go into key commands and check they are not there and the .xml file updates and the referenced macros are gone.

I have spent hours on this trying different things and deleted my preferences my Logical Edit, Project Logical Editor, Staff PResets, Window Layouts, KeCommands, and Configuration files and tried again with the same results.


Could you attach the Key Command.xml file, please (in the state when the Macro is still there)?

This is super strange, it is working now with a brand new one I created though I did that before and it didn’t work. I tried the macro I was referencing 10.5.12 from .10 and things seem to be working just fine now. Not sure why it wasn’t working. Thank you for your replies and for letting me know they should work that was very helpful. Hopefully, they don’t break again for me, I will have to keep an eye on these since that makes me a little leary.