maddening ASIO glitching

A few weeks ago, I made the leap from Cubase LE/5 to Cubase 8. I tend to use a lot of VSTs, and in Cubase 8, I am having a lot of glitching when I use ASIO4ALL, and moreso, my recording interface’s ASIO drivers, when I am playing back my music. I’ve frozen all of my VST tracks, moved the buffer size around, activated/deactived ASIO guard, but none of the aforementioned alleviate the constant glitching! I cannot record any vocals because the playback sputters and it’s incredibly distracting. Even though I only have 8 GB of ram, I still have 2 to 3 gigs free when I am recording. I am about to pull my hair out! Is there anything else I can do to get rid of the glitching that plagues my DAW? I am pretty new to Cubase, and the software has a really steep learning curve, so I am thinking that I must be missing something incredibly obvious. Any insight will be much appreciated!

asio4all is not replacement for a proper asio driver/interface. it can not be expected to handle multiple tracks/vsti’s.
if you want to do multitrack recordng you must obtain a dedicated asio enabled interface. you could try rendering all your vsti tracks to audio or freeze them to lighten the load on your system before you attempt to record your vocals.
in short, dont expect high level performance from a free driver and an onboard chipset that was never designed for multitrack audio recording. there are various reasonably priced interfaces sufficient for a home studio. steinberg has some great hardware these days that would certainly work well for you.

cheers and best of luck, happy recording!

With ASIO Gaurd on (on its highest setting), bump your buffer size up on your audio interface’s ASIO driver (not that ASIO4ALL hack) to its highest; 2048, or around 46ms latency, if it will go that high; 1024, or about 23ms, if it only goes that high.

With that set, now try turning off any Record Monitor buttons on any tracks that may have them on.

Is it still glitching?

If so, what is your VST count? What is your processor type and speed? What is your audio interface?

Search the site. That’s what I did for suggestions. Everyone has a different remedy. Try downloading Lateny mon to target what’s causing the spikes

I’ve been adjusting the buffer for the last hour and I’m getting glitches irrespective of where I place it. :frowning: My buffer size goes up to 4086, but I was unable to try it there, as my computer crashed with the buffer set that high.

For the project I’m currently working in, I have one VST track instrument and two rack instruments. I have an i7 @ 2.2 Ghz with an M-Audio Fast Track Ultra. I’ve also tried to use Cubase with my old Lexicon Lambda interface and I’m still glitching. I don’t understand why this is happening! )=

LatencyMon says my “Your system seems to have difficulty handling real-time audio and other tasks. You may experience drop outs, clicks or pops due to buffer underruns. One or more DPC routines that belong to a driver running in your system appear to be executing for too long. At least one detected problem appears to be network related. In case you are using a WLAN adapter, try disabling it to get better results. One problem may be related to power management, disable CPU throttling settings in Control Panel and BIOS setup. Check for BIOS updates.”

I don’t use Cubase with my network adapter on and my CPU isn’t set to throttle. I have searched the website for solutions, but I’ll keep looking.

I had similar issues and LatencyMon gave similar possible options.

Flash of BIOS fixed every issue I had. ASIO spikes, crash on exit, sudden loss of mouse scroll wheel control, hard pagefaults, and any issues even with network enabled.

I cannot recommend that that is the best choice for you. Just what worked for me.

Unless M-Audio has the world record for highest buffer setting, that’s the ASIO4ALL driver you’re talking about.

It will end in tears. Use the latest native ASIO driver your M-Audio has.

Are any record monitor buttons engaged? If so, power them off to remove them from the equation. ASIO Guard has a dual engine. Force it to disengage its low latency stuff by making sure the record monitors and any other real-time tracks disabled.

We need to see if the problem can go away with even your highest buffer settings and no real-time stuff.

How many VSTs are running real-time right now? That 2.2ghz i7 sounds a bit underpowered. How many cores does it have (real, not virtual)?

You can find the current ASIO driver for the M-Audio Fast Track Ultra on Avid’s website, not on the M-Audio site.

http://avid.force.com/pkb/articles/download/Fast-Track-Ultra-Drivers

Find the one for your operating system, install and be happy! Even with your modest gear you should have some pretty good performance gains once you are using the proper ASIO driver. Good Luck!

Hi,

just to confirm what others said here: Forget Asio4all if you Need low latency.
The Interface plus a very good asio Driver, specifically for the Interface, are the only way to go.

Cheers, Ernst

I flashed my BIOS and my glitching is gone! I can’t believe it. Thank you all so much for your help!! I really appreciate all of you taking the time out of your day to help me with troubleshooting. (=

I have been using the most recent ASIO driver for my recording interface. I like to record my VSTs using ASIO4ALL (so that I don’t have to plug my interface in), and then I record actual audio with my recording interface’s ASIO driver. Before my BIOS flash, I was getting glitching on ASIO4ALL and my M-Audio drivers.

My M-Audio buffer size does go up to 4086; however, I was unable to actually get my system to not crash with the buffer sizee that high. I believe that ASIO4ALL ASIO drivers go up to 2048. I have four cores.

I am having one last issue even after I flashed my BIOS. I have a project with four VST rack instrument (I believe it has 20 different VSTs within rack instrument channels, though) and even though I am not getting any glitching, I have an issue with the VST samples dropping out. If I have the piano sustaining a chord for two measures, the sound drops out immediately after striking the chord. When this started happening, I froze all of my instruments, but that did not alleviate the issue. Is there another simple thing that I am overlooking here that would cause my VST samples to not sustain their sounds for their programmed duration?

I’m sorry for all of the questions, but I never learned the full functionality of the older versions of Cubase I was using, and Cubase 8 is a big learn.

Thanks again for any insight!

Regarding your piano dropouts…it’s not as easy as having MIDI notes overlaying each other and robbing notes, or some other limitation to polyphony?

Is it predictable in that it happens at the same position every time, or do the dropout problems move around?

Good to hear.

Which sampler are you using? If it’s Kontakt there is a “enabled multi-core” toggle that you could try switching either off, or on.

Are any of the samples loading direct-from-disk?

sorry for the delay in replying. i have been out of town and yesterday was the first day i had a chance to fire cubase back up again.

for this particular project, it’s on any Kontakt instrument where a note is being sustained longer than 1 or 2 seconds. i have strings, brass, and piano samples playing, and this happens on every single instrument.

i did have the multi-core enabled, but i hear no difference when it’s on or off. i do have multi processing checked in cubase, though…

is there a global DFD option? i looked at one of my instruments and it has “allow instant playback for samples which are not loaded yet” checked. i’m assuming that would be the same for all of my instruments?

my glitching appears to come and go, so it looks like the BIOS flash didn’t really consistently remedy my larger project. i’m tempted to just buy a new laptop because i am so frustrated.

Sounds like Kontakt is either stealing a CPU core from Cubase, or it may be DFD related. I would try toggling Kontakt’s multi-core setting again.

Also, I would try toggling Kontakt’s multi-core setting to the opposite of what it is. Save the project and reboot the computer.

It’s possible that the core assignments may reset themselves favorably when loaded fresh.

Also, for DFD, play with the settings as described here and see if that solves it: http://www.adsrsounds.com/kontakt-tutorials/how-to-use-and-optimize-kontakt-dfd/

If it’s possible to get into the BIOS I would check if hyper-threading is turned on (if not, I would turn it on).

I would also try as many general optimization things, as are relevant to your laptop and version of windows, as found here: https://www.youtube.com/watch?v=PhQVkv3NM3k

Also check in the BIOS to see if your internal hd is set to AHCI or IDE. Unfortunately, you can’t change it, but it would be good to know. AHCI is what you want.

I would also consider making your swapfile fixed.

Also consider browsing through NI’s Forums for Kontakt issues & advice.
Many people don’t even know that they even have forums on their site.