Magic Mouse 2 scrolling in Cubase 10

I set slow scrolling speed on Magic Mouse 2 but Cubase does not recognized the settings … its very fast scrolling in Cubase 10 … anyone knows some solution ?

I use a regular old USB wired Apple mouse and I have noticed that Cubase responds to wheel motion as though it is on high speed, in spite of the standard OS speed set in Apple’s preferences. Scroll speed behaves normally on all the earlier versions of Cubase. So I’d say something has changed with how Cubase 10.xx handles scrolling input on a Mac. It’s moments like this I wish Cubase restored bigger scroll bars.

This has been the same since I started using Mac in 2013 and Cubase 6? Back then.
I used a Logitech Mac on an iMac and seamlessly switch between that and trackpad.
Cubase need true trackpad support