Magic wand is CRASHING spectralayers 10.0.40

Everytime I select the magic wand tool and begin to select… Spectralayers 10 crashes to desktop. No error, just a poof and its gone…
Anyone else having this issue ?

3 Likes

Can you do a video capture of the issue ? Is it in standalone or ARA mode ?

I can confirm a crash. SpectraLayers Pro 10.0.40 Standalone on Win 11 Pro 23H2.

The crash seems to happen, as soon as I move the mouse cursor - with the Magic Wand Selection tool active - from the spectrogram area into any other area (so the left toolbar area, the upper waveform area or the right Display/Layers area), or if I try to enter the context menu by pressing right mouse button.
If I switch to another tool via hotkey, I can move the cursor outside the spectrogram area without problems.
As long as I keep the mouse within the spectrogram area, I can create selections with the tool tough.

I tested this a couple of times - in fullscreen and windowed, with composit view layered view, with different settings for the Magic Wand tool - and it seems to be somewhat inconsistent. On some attempts I could move the mouse outside and back into the spectrogram area multiple times, but eventually it still did crash at some point.

On a few occasions it also didn’t crash immediately, instead it froze for a longer time. During that time I could see within Windows Task Manager, that SpectraLayers was allocating more and more RAM, up to about 8 GB until it finally shut down.

3 Likes

This happens to me as well.
It looks like it happens when you hovering the magic wand at the left border of the audio file.
It doesn’t happens right away sometimes I have to move around the wand for some seconds.

2 Likes

Yes exactly this.

3 Likes

In my case, in both standalone and ARA mode (C13).

3 Likes

Same here. It’s impossible to use the magic wand.

2023-12-15 17_59_00-Errore

2 Likes

That’s actually always reproducible. I tried from my home PC (different CPU and setup than the studio PC) and this time in standalone. Spectralayers 10 closes unexpectedly every time I move the cursor elsewhere after using the magic wand. Strange that so few of us reported such an obvious bug.

  • Home: Standalone, CPU FX8530, Win 10
  • Studio: ARA via Cubase Pro 13, CPU Ryzen 7, Win 11
3 Likes

I could indeed repro the issue, it seems to be a Windows-only issue (was trying to repro on macOS and couldn’t repro).

5 Likes

I am having the same issue as well. Crash and vanish when using the wand. It seems I can use it a few times (haven’t counted, but somewhere on the 3 rd to 4 th time) before the crash occurs.

I am on Win11, latest update. If any other info would help, let me know.

2 Likes

Same here. ARA and Standalone. Magic Wand. Every time.

Windows Event Viewer gives this:

2 Likes

Great feedback here. I am glad others took the time to check on this bug. Thank you to everyone !

1 Like

For what it is worth, I also see this on Windows 11. My system info:

Operating System: Win64
Chrome Browser Version: 120.0.0.0
Chrome OS Version: NA
CPU: 11th Gen Intel(R) Core™ i7-1185G7 @ 3.00GHz ( x86_64architecture - 8 processors )
Memory: 3.32GB available out of 16.90GB

1 Like

Hi, I found the same bug today.

Fresh installed trial version of SLPro 10.

First what i wanted to try it’s “magic wand”, and gets stable crash after using it.
It looks like: i import audio file (standard, about 15 sec length), press Magic wand, and try to select some freq’s, incl. with shift for multiple selections. Nothing more doing. And with that, after short time appears waiting circle icon and header “program nor respond”, and program autoclosed.
Stable reproductible.

Tried reboot, change audio hardware from wasapi to asio, nope.

If triyng other tools (simple selection, transform etc) it works ok, problem exactly MW it seems.

Win10 22H2, cpu intel i7-8700, RAM 64gb, video nvidia GTX 1660 6gb

1 Like

@scrist @Laturec @Franck_Magnier @lordadb @balinas3000 @freddiprice @john.loughney @Izitskyj
Because this issue is getting so popular (sort of), and because it’s a Magic Wand, and because it’s Christmas, here’s an early patch to fix it !

SpectraLayers 10.0.40.340 Windows Installer
SpectraLayers 10.0.40.340 macOS Installer
image

An official patch should come later in january, with other fixes.

15 Likes

Thank you and merry Christmas!

Thank you for the quick fix, Robin. Seems to work correctly now.

Thanks for the christmas present @Robin_Lobel !
Nice work, it doesn’t crash anymore now.
:clap: :clap: :clap:

Enjoy your holidays !

@Robin_Lobel Thanks, cool.

Thanks for the fix,
Marry x-mas to all on the forum.
SLL