Major bug (4.0.31): Undo and redo act on wrong objects

I’m using Dorico Pro 4.0.31 on macOS 12.3.1 and several times have run into a serious bug. When inputting notes on one staff and pressing cmd-Z to undo the last input, Dorico instead deletes notes in the other staff, in a different bar altogether. In this score, I last worked on the other staff probably hundreds of steps ago, so it definitely wasn’t the most recent item in the undo buffer.

Steps to reproduce:

  • Enter note(s).
  • Press cmd-Z (no user interaction such as clicking anywhere in between steps).
  • Dorico then sometimes deletes entirely different notes in the wrong staff.

This has now happened several times. It’s also the first time it’s occurred, and so far it’s only been happening with one score which I’ve had open the whole time. I’ll try quitting and relaunching Dorico but just wanted to report this in case it’s helpful.

As luck would have it, I’m sitting in front of my MacBook 12.3.1 with Dorico Pro 4.0.31, so have just tried your steps. It all worked as it should, but I’ll keep an eye on it just in case it behaves as you’ve described.

Yeah, this may have just been a “one-off.” It’s the first time it’s happened in my experience. It just looks like the undo/redo buffer got confused at some point and was only reset after quitting and relaunching Dorico.

If it happens again I’ll see if I can figure out any more precise steps to reproduce it.

We have seen occasional reports of this bug, but as yet it has been impossible to track down. What appears to be happening based on the description of the problem is that when the menus are updated (to enable or disable things based on the state or selection, or when you change mode), under some extremely rare circumstances, somehow some commands are getting mapped to the wrong menu, which means that a particular command – whether triggered via the menu or a keyboard shortcut – will do something other than what it is meant to. We have a suspicion that this could also be related to the also-non-reproducible crash that some users experience when switching mode in Dorico. Unfortunately to date we have no hard lead on how to reproduce either problem, which makes fixing them impossible for the time being.

Thanks so much, Daniel. I’ll keep my eye out for any steps to trigger this bug in case it occurs again.

Good to know that this isn’t one of those “It’s not a bug, it’s a feature” things! :slight_smile:

I have noticed strange behavior as well, including just the other day; pressing undo in certain circumstances in engrave mode will not actually undo everything and will skip certain steps. I was on a limited time constraint yesterday so I couldn’t thoroughly investigate, but the next time it happens I will try to re-create it and add a cut down project here. At least with what I observed yesterday, I had added some notes in write mode and then switched to engrave mode and made a few edits. When I went to undo a few nudges, Dorico completely ignored everything that I had just done in engrave mode and started deleting the notes as if my adding them was the last action.

1 Like

Same here but many times I’m not even sure what is being undone. Will keep my eyes peeled.

1 Like