Manual stemlets sometimes work, sometimes not

My house style involves using stemlets in triplets to avoid extraneous triplet brackets, but not in other contexts, so I need to manually create them on a case-by-case basis. As you can see in this example GIF, in Dorico 1.0 sometimes this works and sometimes it doesn’t. Here you can see the exact same music in two different staves; it works on the top staff but not on the bottom. I haven’t been able to find a reason to it, but I’d appreciate any suggestions.


stemlet.gif

If stemlets are turned off, we will never start or end a beam with a rest, even if the user tries to manually create such a beam with the ‘beam together’ command. To switch stemlets on, set ‘Beams and rests’ to ‘Use stemlets’ on the Beam Grouping page of Notation Options. You can then suppress stemlets in the cases you don’t want to see them, hopefully.

Thanks for your reply, Daniel. But then why am I able to create one stemlet on the upper staff of my example? It sounds like you’re saying I shouldn’t be able to create either of these stemlets because they start or end a beam, when in fact I’ve been able to “force stemlets” roughly 70-80% of the time throughout this score (about 30 of these groups have worked). (This is, incidentally, the score of mine you have already.)

If I’m understanding you correctly, I’d request you reconsider for future updates – seems like I should be able to “beam together” anything I want, in the abstract… Turning on stemlets and then suppressing them in all the “normal” cases ends up making a lot more manual work than being able to leave them turned off and selectively creating them. Stemlets are super useful when they are used selectively, but (IMHO) look ridiculous when the entire score is full of them.

I just played around with a single triplet (so it really really must be “exactly the same music”).

I can create the stemlet if the rest is a forced rest, but not if it isn’t.

I haven’t knowingly changed any engraving rules relating to stemlets.

Try clicking the “force position and duration” property for the rest, in the triplet that won’t work.

Flipping that property does seem to work, so I guess that’s a workaround for the moment. The odd part is that most of the other ~30 cases in this score have worked without “force position and duration” activated (screenshot of one attached); it’s just a few that don’t work. Definitely not an ideal workflow, since there isn’t an easy way to flip that property with a keyboard shortcut. (I guess I’ll have to resort to a Keyboard Maestro macro.) But thanks for finding a workaround, Rob.


unforced.png

I don’t fully understand what I’m saying here, but from a discussion in another thread somewhere, it seems that some operations in Dorico may “provisionally” switch on the force position property to try do some operation, then discover that it can’t be done for some other reason, and end up leaving the force position property “still sort of switched on, but not actually displayed as being switched on”. (My brain faded part way through the explanation of why it this was intentional…)