Mapping CC#1 From Keyboard To CC#99 In Inspector?

I may be having a senior moment.

I have an old VSTi where there is a parameter hard-wired to CC#99. I would like to twiddle that with CC#1 (mod wheel).

I coulda sworn there was an (easy) way to use the Inspector to route the incoming MIDI from my keyboard’s CC#1 to CC#99 in the VSTi so I can record my mod wheel twiddles, but have them show up in the Key Editor as CC#99s.

Am I making sense? :mrgreen:



Cubase Pro?
Use the Input Transformer (I think you know how to do that, yes? :wink: )

So I tried using the Transformer plug-in (it looks like the Logical Editor) and it works (ie. twiddling the Mod Wheel changes the VSTi parameter for CC#99) but -only- if Cubase is stopped. That is, I can play and the VSTi responds as expected. THANKS!

BUT, if I hit Record or Play, it does not work. ie. the twiddling the Mod Wheel does not affect the parameter in the VSTi.

Any ideas?

Is there some MIDI which gets ‘filtered’ during record/playback but not when Cubase is stopped?


No, not the Transformer Insert FX. The Input Transformer (the “crooked arrow” icon near the top-right of the Inspector)
Although, you can use the Transformer Insert FX, so long as you activate its “Record” button.

OK, I tried the ‘crooked arrow’ as well. Same results: it works when Cubase is stopped. But not during playback.

However, the transformer -does- appear to work as advertised, ie. when I twiddle the Mod Wheel the recorded MIDI appears on CC99, so that’s progress.

Any other ideas?


This just in…

I took the frustrated man’s way out, removed the VSTi and started over (but keeping the same MIDI track and data). And now it works.

And the reason that’s bad is that now I don’t know what was going on.

There was -something- ‘forcing’ the parameter (Speed) in the ‘off’ position. ie. I could see on screen that when I tried to move it with the mouse during playback it would instantly snap back to off as if there was some hidden controller data holding it in place. I was wondering if there was something like controller data from somewhere, but if that were the case, I assumed that when I removed the VSTi and replaced it I would have the same symptoms.

It’s. The. Not. Knowing.