Markers change position when changing tempo

Dear Embee and Andre,
I understood that markers were linked to video time, so they should not move relatively to the timecode. If your project behaves otherwise (and that you can easily exhibit the problem), it might be useful to post that minimal project with simple instructions to reproduce the problem. This is the most useful help for the dev team IIRC

It’s very simple to see this happening. Start an empty project, attach a video and add markers. Now change the starting tempo or add tempo changes in the tempo map and you see that the markers are on different places in the video.

This happened with the first film scoring I did when this feature was added to Dorico and it happens still now. So I don’t think it’s a project related problem. I tried it yesterday and it still behaves the same way.

Ok, I spent about 1 hour playing around with this and watched the Dorico video about working with video in Dorico and markers. I have to conclude that they do stay attached to a specific frame in the video and so work as expected. Not sure why I could not get this working correctly before.

I created different markers in a short video with a short piano score.
I added tempo changes, immediately and graduals and inserted bars on different spots: The markers stay connected to the same video frame and the smtp numbers stay the same.
I moved a marker left or right which of course will move the other markers as well, but the smtp numbers in the markers stay the same.

So as far as I can see now, they do act correctly as scene markers, staying connected to the frames and not to the music.

Thanks, Andre, I did the same here and also found out that most of them (!) they stay attached to the same frame. However, once I wrote music in the score, I still found some markers towards the end that were moved. Suddenly the music is in a totally different place than before, but I didn’t insert new measures. Beats me why this happens. It’s also a lot of work to line the music up again, once it has been moved.

This is why I suggested you to post any project that exhibits the problem (as this is not as it’s supposed to behave) either here (zipping the file) or to Daniel or any of the dev team if it’s private (copyright issues).
It’s the best way to get rid of (possible) bugs.

I did some more testing, adding music, deleting music, also recording music live, but the markers keep steady in their time code. Not sure anymore now why it would change. The only thought that comes to mind is that somehow you change the marker position itself, but that’s of course obvious. I wonder now if maybe you accidentally had the Insert option on? That would push music from their marker spot for sure.

Hi Andre, Thanks for testing so thoroughly!
I’m 100% confident that I did not use the insert option; this is a tool that I only use on rare occasions.
I did some testing myself too and found out that, when you click on the marker you go exactly to the specific cue in the video, so that’s okay. Remains the fact that music and markers don’t line up anymore when I’ve entered music somewhere in the track. Since I’m not a composer who writes a scene straight from A-Z but tends to compose ‘randomly’ on a scene, the moving music/markers (still not sure what’s really happening) is a big PITA.
Marc Larcher’s idea is a good one, I will do this (hopefully) tomorrow, but anyhow soon.

Hi EmBee,

If you’d like to line up the marker(s) with the music, there are multiple options: i) you can drag the marker in write mode, so it snaps to an exact rhythmic position and adjusts the previous absolute tempo change to make sure the music and marker in sync; ii) if your flow is using a single tempo, you can use the find tempo dialog to find a tempo where all important markers are falling on a beat; or iii) in play mode you can graphically edit the tempo track and you can see whether the markers moved to the expected positions or not. You can find more information in the video that was linked earlier, or here: https://steinberg.help/dorico/v2/en/dorico/topics/notation_reference/notation_reference_markers_c.html

If you work in random order on the cues, I think Rob’s advice is a good one, create one flow per each cues. Then you won’t need markers at all, just make sure that each flow has the same video attached with the correct start position.

If you find that markers still move their position relative to the video unexpectedly (ie the time code they display changes), please send me (or Daniel) the project that can reproduce the problem to a(dot)keri(at)steinberg(dot)de with the steps to reproduce it.

It’s been some time since my last post about this, but I found out a few things. First of all: the markers indeed do stay at the same time frame where you put them; it’s the music that moves to other points. It feels a bit awkward that I created a thread about it, thinking the markers moved, but it appears to be as I wrote, that the music moves away. A lot of people tried to help, thanks for that!
So now remains the question of how I can make the music to stay also attached to the same time marker, instead of moving ahead or away from the cue? This would really save a lot of time, as I’ve spent pretty much time aligning everything again. Maybe it’s something really easy, or maybe it’s simply not possible yet. Either way, it would nice if someone can tell more about that.

The music moves away from markers when you change the tempo, that is supposed to happen. Markers stay connected to the movie.

I don’t want to keep repeating myself, but have you tried using a separate flow for each cue? That way, you can guarantee ONE point will stay synchronised - typically the start of the cue. When you attach the video to the flow, you can specify the time offset in the video where the music starts.

Then you can tweak the tempo to line up the end of the music and the video cue, and IIRC there is a tool in Dorico to calculate the exact tempo to do that.

The default gap between flows for playback is 5 seconds, but you can change that to 0 if you want.

Logic user here trying to make the switch to Cubase. I know this is Dorico related, but the same issue happens with Cubase. I really want the markers to be locked to SMPTE (along with video). If my session starts at bar 1, and my starting timecode is 1.00.00.00, if I have a marker at say :15 (one could say, “car slams down on pavement” but it’s not falling on a beat and I want to find a tempo that works so that it will land precicely on a beat, I would typically change my tempo until the marker and video scene lands on a beat. Instead what happens, is I change my tempo and the marker moves. See attached examples. In my opinion, this shouldn’t happen. The markers should lock to SMPTE.


ExLogic, I think you’ll have more success with this question in the Cubase forums here, if you’ve not already posted it there.

Will do for the future. I’ll be back here with Dorico questions soon enough… I did figure out this issue for those lost Cubase souls who might land here: right-click on marker track, select track settings, make sure “toggle time base” button is available on your track, then toggle the button (looks like a note) from musical to linear. Thank you!

Hi,

I also have this problem in Dorico 3.5. Although the actual timecode doesn’t change, the marker boxes containing the timecode are moved from their positions when I do shift T and write for example “poco rit”, making an inconsistent mess in my score.
The project is based on a MIDI file imported from Cubase containing tempo and markers. Without altering anything tempowise, Dorico displays tempo markings correctly. However, wherever there is a ritardando or accelerando followed by a new tempo it simply ignores it which is why I want to be able to write it in myself without messing up the marker boxes. But well, it doesn’t work obviously!
Any ideas are greatly appreciated.
I don’t want to use the text feature as it would take four times as long to put tempo markings manually above every group in the score.

I do not want to offend anyone but is the concept regarding linking real time (SMPTE) and musical time (bars and beats) really so hard to grasp?

Say, you have a song at 120 bpm in 4/4 and a marker at SMPTE 1:00 which is beat 1 of bar 31. The marker is attached to the SMPTE Time and will show you where in the score that point is.

The marker is NOT attached to bar 31!!!

When you change the initial tempo to 240 bpm you will have twice as many bars in the same time, hence the marker, which is STILL attached to SMPTE time 1:00 will now be displayed at bar 61, because beat 1 of this bar is now at this time position.

The marker does NOT change its time position, but it will MOVE in the score to show you that now another bar falls onto that position.

If you have composed music that started at that original position you must understand that your music did not start on SMPTE 1:00 but in bar 31 which at a tempo of 120 bbm happens to coincide.

After changing the tempo the music still starts in bar 31 which now does not anymore coincide with SMPTE 1:00, hence the marker will be shown at whatever bar is now falling onto SMPTE 1:00.

Also a less drastic tempo change like a ritardando shortly before bar 31 will have the same effect. Dorico interprets the “rit.” text and performs a slowing down of the tempo which means that at SMPTE 1:00 your music will not have arrived at bar 31, therefore the marker will (still not move, it stays firmly connected to SMPTE 1:00, but) be displayed a little earlier in the score to show you what beat now coincides with SMPTE 1:00

This is the intended and logical behaviour!

What you want is some kind of 2nd level attachment: you want a new musical section (or cue) to start at a specific SMPTE time regardless of what is happening before.

As a long time logic user myself I would also very much hope for such a solution which could be called a “Cue marker” (in contrast to SMPTE marker):

If I would rise the tempo before such a cue marker the programm would insert bars to fill the time up to the fixed cue marker and probably one incomplete bar or another tempo change only for the last bar (to make it into a kind of fermata), or the other way round: if I lower the tempo before such a cue marker the music before that marker would “disappear” (but stay in memory, imagine overlapping regions where only the region that starts latest will be played).

Dorico offers you exactly this kind of solution by starting a new flow at every new cue as has been suggested here for multiple times.

1 Like

Thanks for your swift (and energetic) response.

Look, I get the concept you are trying to explain, but please let me shed some more light over what I’m trying to do.

All my tempo changes and markers were already edited and at their perfect positions in Cubase prior to exporting the MIDI-file. When imported in Dorico, every marker was indeed at its correct position with correct timecodes, as well as all the tempi playback-wise, BUT only some tempo changes were actually visible in the score layouts. So, here comes my ultimate question: if hitting shift-t and typing gradual tempo changes adds to the existing tempo in the flow (and therefore shifts the position of markers) WHY are only static tempo changes visible in the score layouts after MIDI import while accelerando and ritardando followed by a new tempo are left out??
If it was consistent and every accel., rit. and new tempo was visible, I wouldn’t have to try adding anything at all and the markers would stay intact.
If I check the signposts it’s all there but as I said, Dorico only shows the static tempo changes in the score layouts, not the gradual ones. So, HOW am I supposed to tell the reader of the score and parts that there are gradual tempo changes along with additional new tempi if I can’t use the shift T popover because it will apparently add values to the existing tempo?
I tried fiddling around with text but it’s very time consuming and cumbersome.

Also, this is one orchestral piece in its entirety, supposed to be played live -fino in fondo- by an orchestra with audience, hence why I don’t want to use different flows. Or maybe I’ve misunderstood the concept of flows entirely as I’m new to Dorico.

If I am still missing the obvious, you may call me an idiot and I will not take offense!

Using separate flows makes sense if you compose in dorico to picture as the OP does, when you are done composing you can copy/paste everything into one flow.

This is not what you are doing as the composition is done already and you only want to produce a professional score with dorico.

I haven’t been diving too deep into tempo operations within dorico, so these are just guesses:

For a DAW or a scoring app there is no such thing as a gradual tempo change. Behind the scenes they are a series of static tempo events. I would assume that your DAW exports static tempo markings as text, and the actual tempo change (the midi message) will be exported separately on the tempo track.

Your gradual tempo changes however probably are programmed very detailed to exactly match the picture.

Dorico probably interprets tempo text correctly, but how should it interpret a ritardando exactly in the way it was programmed in the midifile? The single tempo changes that make up the ritardando mus be kept as they are.

Would Dorico put in “rit.” as tempo text, it would apply its own gradual tempocurve which then would interact weirdly with the tempo events from the import, so it is probably a good idea to not try to interpret them.

Isn’t there an option in Dorico to simply ignore gradual tempo instructions either individually in the properties panel or as a global setting?

Alternatively, can you create a new symbol for gradual change that does not affect tempo?

Or maybe create a text that contains a hidden character (like a zero-width-space) so it reads “r​it.” but ⁣won’t be detected by Dorico.

(I actually put one ot them between r and it. - maybe try to copy it into Dorico).

2 Likes

I really appreciate you trying to help me out here, so thanks a lot MassMover.
An option to ignore gradual tempo changes would be a true painkiller, but unfortunately I don’t know of any such option. If anyone else knows, please chime in.
I’m not in the studio right now but I’ll try your suggestion with using space in front of the gradual tempo instruction (” rit”) and report the result when I get back.

Just tried it: a hidden space unfortunately does not fool Dorico’s text parser.

But you can switch off the playback of any tempo marking including “rit.” individually in the “general” property field, this works here on my machine.

1 Like