Marquee tool being selected autonomously

After inserting an instruction for a player using Shift-X (Mac) to insert text, I notice that if I hit ‘escape’, to return to normal write mode, Dorico puts me into marquee tool mode and anything I click summons an uncalled for marquee box. I find I have to click twice on the score to get out of marquee mode which I never selected.

I know that bottom right of the screen, there is a choice of marquee or hand (drag score) mode, but I don’t want Dorico to move into either of those modes after having inserted a text item above a stave.

Is there a way to stop Dorico from doing this?

I noticed that behavior too since Dorico 4 and… I hate it! Please beloved Team, make it stop :wink:
I’m using Dorico 4.0.10 and noticed it while on Big Sur (haven’t tried this today, Monterey)
[Edit] I tried it on Monterey and don’t have that behavior, but maybe it’s not consistent.

I’ve had that too

I do not experience this behavior in D4.

1 Like

Erratum: Dorico actually only sometimes does this, though I’ve not discovered what the trigger is. It may be that pressing ‘Escape’ key avoids switch to marquee mode. Either way, it could be a little bug.

BTW am using Dorico v.3.5.

The Shift key switches between the two tools, so could the trigger be unintentionally pressing Shift?

1 Like

Actually, Mark, on my computer, it’s h that switches between “normal” (for me), which is hand tool, and “strange” (marquee selection) which I abandoned once the system track was implemented :slight_smile:
But you’re right that for those who use marquee selection as “normal”, shift toggles to hand tool while pressed. I don’t find the opposite to be true.
[Edit] My bad. You are absolutely right, the opposite is true and I apologize! So maybe there’s a kind of “shift errance” while escaping from the text tool, as if the shift key was sending information as pressed while it’s not.

Thanks Mark, but it’s not switching that’s the problem, it’s automatic turning on of Marquee tool mode after inputting a text item into a stave, when neither hand nor marquee tool modes were summoned.

I take your point about ‘shift’.

To put it in clearer language:
H changes which is the preferred tool.
A regular mouse drag uses the selected tool.
Holding Shift and dragging uses the other tool.
(The latter does not highlight the actual tool at the bottom, but the cursor changes.)

I learned about this when I decided I wanted to use H for some multi-key shortcuts, because I had no use for a shortcut to switch tools (when Shift is always available).

So … Evan, is it possible you hit H accidentally? Is the marquee tool highlighted at the bottom, and you have to switch it back?

Nope. I do not touch the ‘H’ key.

I’ll try to see what action is causing Marquee to activate.

Me neither. There must be something with the shift key. I tried again and could not reproduce the problem…

This has been reported and they’re aware. There is, as Daniel would say, some sort of boring technical reason for it…

1 Like

Ah – the same as this one, I guess. (This was also mentioned as early as Oct. 2019.)

⌘ Return also finishes text input. I wonder whether that would make any difference.

FWIW, I have not noticed this happening to me.

It’s new in Dorico 4, and it’s related to the fact that we now try to select the text item after you finish inputting it, which in previous versions we did not. Because of the specific way text in particular works, creating text and then selecting it has to be done as two discrete actions, and if you manage to get a mouse click in the precise moment between those two actions being processed, the mouse button release message can get lost, resulting in Dorico thinking you’re performing a marquee drag.

2 Likes

Yes, actually, Daniel, this explanation helps. I was using a click outside the text boundaries to escape that text and it causes that marquee select. Now I know why. I have to get used to cmd-returning to change that task.

1 Like

Yes – When I read it I realized the reason I haven’t had the problem is that I’m in the habit of inspecting text for a second after I close the editor.

Yes, same was happening to me with this action. I find the only way out is to click twice outside the text box and wait. :face_with_raised_eyebrow: