massive asio spikes drawing a selection (video included)

I seem to be getting massive asio spikes when drawing a selection in my projects, the video is with asio guard turned off to show the issue more clearly.

Have any of you seen this before? I have just changed computer and am having the same issue now on the new one ,the only parts I kept are my Nvidia GTx 980 and my 2x uad cards… tried disabling the UAD cards in case it was a bus issue

display is running at 4k but issue still happens when dropping to lower resolution. with asio guard turned on or off there are noticeable audio drops when drawing a selection or draging + dropping an event.

here is everything I have tried… any extra suggestions would be great!

Disabled UAD cards
Tried running GFX card at full fan speed, in case it was overheating
trashed preferances
tried with no plugins at all loaded (still a noticable asio jump)
Tried the top stickied post for disabling GFX acceleration

CPU is a 8 core 5960x with hyperthreading turned off…

any suggestions are welcome! :frowning:

I was reading this topic earlier and you could potentially benefit, …, worth a try. I am going to do this when I get back to my studio, on the cubase registry hive. (looks like Win8 you have there, not sure).


Have tried that registry thing but it unfortunately has not made any difference… even tried disabling the video card driver completely and the same thing happens… its quite a strange one

I am seeing this. It is the worst when the window is maximized here. Does it make a difference if you make the window smaller (for testing)?

I was using the on-board video of my i7-3750 cpu, and I found a solution- I bought a cheap video card and it got better. Not cured, but much better.

I bought this:

yes, if you make the window tiny it is fine… interesting

I’m running at 4k, so i’m probbly seeing worse results than most people would perhaps…

previously in cubase 7, drawing a selection box would be be a bit jerky, like there was a slight delay in doing it… perhaps to make that smooth this issue was introduced…

wonder if this is a ‘known’ isssue then? will we perhaps see a fix? perhaps its actually affecting most people but they dont realise?

I have the same, but not as severe. That is until I upgraded to win10, now it’s worse.

Just confirm (no solution sorry) that I’ve tried it and whilst I don’t get peaks - there is a significant CPU load being reflected in the performance meter when I draw a select in full screen mode - but virtually nothing in window mode -

I suspect it’s a code issue and not your set up -

Was the CPU load heavy on that arrangement window? or do you get peaks even in a blank arrangement window too?

do you have asio guard turned on? if you turn asio guard you will most likely see the asio meter jump a lot more clearly
i don’t get peaks in a blank arrangement window but i do notice the asio meter going up a fair bit

it doesnt always peak like the video, sometimes its just a 30% jump in asio activity. depends on how heavy the project is

thx for testing!