Master Fader midi control

Hello guys!

I have a big trouble with my midi mapping. I have 9 faders in my midi keyboard and i want to control each track volume witch 1-8 fader, and the 9-th left for Stereo Out. Faders 1-8 works perfect, but when i open other project 9-th fader not working. How to set this to adjust volume only for track “Stereo Out” ? It is set to CC7 but… Thanks for any help.

Hi,

Do you use Generic Remote Device? Or how do you control the channels?

Yes, i use Generic Remote. I’m trying to configure it on new project with 32 audio tracks, and it works for it. But when I open other project this master fader is set to control track number 33, but in this project is about 20 tracks. Cubase correctly match tracks for fader 1 to 8 but there is problem with this stereo out becouse two last tracks is Stereo In and Stereo Out. And when i open project with 2 tracks Stereo Out will be on 4-th fader but i want to have it anyway on my 9-th.

Hi,

I’m afraid, Cubase assigns the Faders kind of “hard”. So if you assign it to the Master Fader in the project with 32 Channels (and the Master Fader is Channel 33), then it’s hard-assigned to Channel 33. It doesn’t matter what Channel is 33rd one. So if you would open a project with 64 Channels, the “Master Fader” controller would control the 33rd channel.

Can you change the MIDI Message, what your MIDI Controller sends out? You could emulate Mackie Control, then you could do it the way you want to.

Thanks for response. I can olny configure it as in the table below but i think it is not what are you talking about.

Hi,

PitchBend is OK, this is what you need. Mackie Control is using PitchBend to control 8 faders 1 Master fader. Map your faders this way:
1st fader: PitchBend, MIDI Channel 1;
2nd fader: PitchBend, MIDI Channel 2;
3rd fader: PitchBend, MIDI Channel 3;

9th fader: PitchBend, MIDI Channel 9;

In Cubase add Mackie Control Device, and set your MIDI Device as an Input. Disable MIDI Input of the Generic Remote, to don’t double remote devices.

Now, you should be able to control first 8 channels via your device, plus the Master Fader. If you have any buttons on your MIDI Controllers, you can assign them to Bank (or Channel) Left/Right, so then you can even switch banks/channels and control all your tracks. Be aware of limitations of non-motorised faders. For this Generic Remote is better, because you can use the pics-up mode.

Maybe you can combine it and use Mackie Control just for the Master Fader (PitchBend on channel 9), and other tracks control via Generic Remote and MIDI CCs you already have.

So what i have done is:

  • Remove “Master Fader” from Generic Remote
  • Add new device - Mackie Control
  • Set in my keyboard 9th fader CC to 144 and channel 9 and…

IT WORKS! Thanks a lot for your time and willingnes :wink:

Great!

Just one more addition info. Avoid MIDI CCs 16-23 and MIDI CC60 on your midi device. MIDI CCs 16-23 are used to control V-Pots (knobs) on Mackie Control Device, so you would change some parameters (Pan, by default). MIDI CC60 is used for the Scrub Wheel.

Here you can see the whole list.

Thanks, whan I took a look at this pdf i noticed that this Mackie Control uses midi notes as commands. For instance when i play a chord it mute 3 other tracks. But i find a solution just need to change global channel of keyboard to 11. Thanks again.

I have one more problem. Now I am trying to configure my keybord to work as Mackie Control. I have a problem with Shift button. In Devices menu i can set command for “Shift + F1” combination. Command for “F1” works so it’s not a problem here but Cubase don’t see when i push Shift just soloing track (shift + f1 - delete all solo; f1 - solo track). I set Shift button to send midi note like in pic below. Any suggestions? Here is note codes which works for my keyboard in this pdf file there is 1 octave difference.

https://www.native-instruments.com/forum/threads/mackie-control-mcu-parameter-id-codes-template.266581/

Configuration:

Which note which code:

And Midi commands for Shift + F1:

Solved! It is not Shift it’s named Enter in this table. Note: B4

Hi,

It’s a bit tricky with the Shift key. On HW, there are two modes. You can press it down, and when it’s down, you can press another button. Then you can get Shift+X. Then you release the “X” key first and the Shift key after.

Or you can use the Shift key as a switcher. If you press it (Note On) and immediately release (Note Off), then it works as a switcher.

Hi
Thanks for the tip but could you please detailed your process…I have an Oxygen 61 (blue) with cubase 8 pro. Everything works fine. I could configure generic remote properly i control all I want but I would like too that 9th fader of my oxygen be fixed only for master volume (even when adding more tracks, i would like it not to move accordingly)…and what about mute function? (the buton just below the 9th fader) I would like to dedicate it only to master channel as well

I think I get your 2 first points…after i am a bit stuck :wink:
Thanks in advance for your help

Hi,

Mackie Control protocol (which you are going to use to control Master Fader) sends Pitch Bend data to control faders. For the matter fader it send the Pitch Bend at Channel 9.

So the last point was to set your 9th fader so it seems Pitch Bend data on Channel 9.