Master Page Problem

Is anyone else experiencing this?

After making changes to the Master Page “First” in a Default Part Set, the Part layout subsequently becomes based solely on the “Default” page (the “page 2 onwards” one), and I don’t have a “First Page” anymore. This happens everytime. I then have to go to the first page, make a Master Page change to set it to “First”. Why??? I thought Dorico automatically sets the first page of parts to “First” and the following pages to “Default” without having to make overrides. Is it expected behavior that if a user makes changes to the Master Page the parts lose their “based on” links? And a further frustration is that every part needs to be fixed to point its first page to “First Page”. I don’t believe this happened in previous versions. This seems to only happen if the Master Page is edited for Parts (not the Full Score).

Perhaps other users could try this out and see if it happens to them as well.

The only explanation I can offer for this is that you must be making an edit to the master page that removes the main MA frame chain, so when Dorico tries to lay out the music, it can’t find the frame chain it expects to find on the First page pair, and hence it resorts to the Default page pair instead.

Daniel,

I’ve done the same type of editing to the First Page and the Default Master Pages.

The only thing I did was to draw in 3 text frames, and add 3 music frames (for page one) and 2 for page 2, filtering each music frame to show different flows. (This is a collection of small 8 or 12 measure songs for young players - total of 5 laid out on 2 pages). I assume the Master Page Parts Layout filters the music for the particular instrument behind the scenes, because this is working correctly. So I end up with with a correctly formatted Flute part with Flow 1 Title and Music, then Flow 2 Title and Music, then Flow 3 Title and Music all on page one, then Flow 4 and 5 on page 2, and so on for each part. The only thing not working correctly is the fact that I have to manually set page one to “First Page” for each part. This is not necessary for Full Score Master Page Edits, so I am curious as to why the extra work to get parts correctly orientated to “First Page”, then “Default”. It just seems to me that something must be not working correctly.

I don’t think you should use the ‘First’ master page for this – you should define a new master page based on ‘First’ and use that. You are indeed, as I suspected, setting up a mismatch between the ‘First’ and ‘Default’ pages that means Dorico can no longer use the ‘First’ page automatically. Regardless of whether you use the ‘First’ page pair or (as I recommend) another one based on it, you’ll still need a master page change to make Dorico use it.

I will try that. Thanks for your help Daniel!