Master Page settings

I’m new to Dorico (3.5) and to this forum. I wrestled my way trough help pages and guided tours but there are still a lot of things I can’t seem to figure out.

One important item is this: I would like to have 2 systems om every page of my score. I edited the ‘Casting Off’ option (in ‘Layout Options’) to 2 systems, but this only seems to apply from page 2. The first page has only 1 spread out system. If I change Casting Off to 3 systems, the first page has 2 systems and from page there are 3. What do I do to change this behaviour?

Welcome to Dorico and to the forum, @kleinesteentjes!

Something tells me Dorico is not able to fit your two systems into that first page with all other settings + casting off = 2, which is why it is not doing it. When you change casting off = 3, you may be effectively forcing it to override some of these other settings…

The easiest way we can help you is if you post the project—it can be a cut-down version, just enough to produce the effect so we can investigate all your settings and hopefully provide an answer.

Welcome to the forum. This sort of thing is pretty common. You might want to check your settings in Layout Options–Vertical Spacing–Ideal Gaps. The values might be set too high. Try some lower values for spacing between systems and inside systems.

If these don’t fix it, you can use the “Make into Frame” function to force the first page to have two systems.

Is the checkbox for “Scale number of systems by frame height” activated? If so, Dorico reduces the number of systems per frame for frames smaller than the default - this is because with all the extra info often on the first page, you might comfortably fit only 8 systems in a part, whereas 9-10 easily fit on subsequent pages.

If deactivating that checkbox doesn’t work, make sure signposts are shown for system/frame breaks and check there aren’t any existing system or frame break signposts (the pink ones) that essentially override your casting off settings.

Hi Lillie,
Thanks for your reply. Unchecking the ‘Scale number of sytems by frame heught’ tick box did the trick. I now also have 2 systems on the first page.
However, distances between staves on the first page are now different from those on the second page. That’s probably because of the title information on the first page. Is there an easy way to override the automated staves distances on the first page in order to have the same stave distances on all pages?

At some point, it’s easiest to switch to small manual adjustments using the staff spacing tool. Some manual adjustment is usually inevitable anyways, if you’re picky (like I am).

1 Like

@dankreiter: Ok, I think I will try to get more accustomed to Dorico first and dive into details along the way. Learning proces is longer if ones tries to work with two different notation systems (like me)!

Because the First page has the top system start lower down the page than page 2 onwards, I think it’s fair that the staves on p1 are therefore a bit closer together. There are various other things you can do (like changing the music frame margins, either for the entire layout or just for the First master page by editing it and changing the padding of the music frame on it) that will affect the total vertical space that staves/systems on a page can occupy.

You could also try increasing the minimum gap between systems a bit, as this may affect the 1st page apparently more than subsequent pages due to the extra space allocated when staves are justified vertically (note the difference between only systems justified and staves and systems justified shown in the example at the bottom - that’s a handy trick to know about).

@Lillie: Thanks, I will keep that in mind. Is there a way to diminish the vertical space the title (and possible subtitle) occupy on the first page? Thanks!

Yes, but for that, it’s generally best to edit the master page.

Hi Dan,
I read your article on working with master pages. What I’m still struggling with is changing the token of the flow title. Since I’m working on a one part work, I don’t seem to need a flow title and I would like to remove it alltogether since it would create extra space for the music systems.
However, after double clicking ‘Default’ in ‘Flow Headings’ (in ‘Engrave’), I tried to delete the flow title token which appears but I don’t seem to be able to ‘Apply’ that new setting. In the upper right corner the ‘Apply’ label stays inactive during the process and at the end nothing is changed. What am I doing wrong?

try to diable flow headeers via the Layout-Options (cmd/ctrl-shift-L)

Set it to “never” in your case.

I suspect @kleinesteentjes is referring to the running header at the top of the page rather than the added flow header at the start of each flow.

It may be that one needs to click outside the frame after deleting the flow title token in order to activate the “Apply” button.

Yes, you can’t Apply when the text frame is still in active editing.

@klafkid: Thanks for your suggestion. When I set the Flow Headings to ‘Never’, the title of my work is gone (which I want to keep) but I still see “1. Flow 1” at the top. ??

@klafkid: sorry, I messed up. Your suggestion works!

1 Like

@Derrek and dankreider: you’re both right: I have to click outside the window to make the ‘Apply’ label active. Thanks!