Maximizer (in channel racks) freeze BUG

Hello, I think I’ve discovered a bug in Cubase.

  1. Make instrument channel.
  2. Activate maximizer in channel racks, make it loud enough to hear the difference
  3. freeze instrument and channels
  4. maximizer becomes very quiet (maybe deactivated at all)

to make maximizer loud again you need to unfreeze the channel, delete maximizer and reactivate it again in channel racks.

I am using MacBook Pro 15 late 2016, Sierra 10.12.6, Cubase 9.5.20

Same on Windows 7. It seems that when you freeze/unfreeze the instrument and channels, the Maximizer mix is changed to 0%.


I can confirm, and I report to Steinberg. The problem is with the “Mix” parameter. This seems to be reset, while freeze. Once you touch the Mix parameter of the Maximizer, you get the right volume.

Just tested cub10 trial. The problem is still not fixed in 10.0.10