MB Pro 10.9.2 and C7.5.10 - Major Audio problems/glitches

I don’t often post here but have been lurking around for a few years - However I am now at a situation where by DAW setup is no longer usable in any great capacity :unamused: and I need your advice/guidance before I think about spending money.

I run a early 2011 MB Pro with a 2.3ghz i7 along with 8G RAM and a OCZ 512MB Vector with 2.3G i7 with Cubase 7.5.10 & Reason 7 [Plus a selection of VST’s]. Outboard gear is a Propellerhead Balance audio interface and a Virus Ti. For my display I use a Dell 2560x1440 WQHD 27" monitor driven via mini display port to a dual link DVI adaptor and the laptop screen.

Over the past few months my setup appears to seriously struggling in the performance department. By performance I mean that I can not run anymore than about 5 or 6 VST tracks in a mixture of Virus external patches and internal VST patches without cubase grinding literally into a stumbling jittering mess. I have all sorts of audio glitches and random sounds being produced and the VST meter showing it’s maxed out in ‘real time peak’ pretty much at around 90% - Even tonight I created a basic two track project using Halion and video’d the problem which is here: http://www.sync24.com/steinberg/IMG_1602.MOV as you can see from the video clip cubase is pretty unusable due to the glitches and general poor running of the code.

Other issues: Hanging cubase video service processes [videodecode/videopreload] - these report as ‘not responding’ in the OSX process table. Killing them from the OSX shell has no affect.

What have I done so far? I have pretty much done everything I can think of to eliminate the problem but it still exists. [By the way I am a Linux engineer by trade so I know my way around the OS and the components]

Things tried:

Re-formatting my SSD, turning trim on [and off], validating the disk IO using Black Magic Disk tester [IO Is circa +400MB per sec across the board]. A fresh re-install of 10.9.2 - recovery of apps from Time Machine, rebuilt kext caches, removed all previous versions of cubase [was seeing this in 6,7.05 and 7.5] and reinstalled 7.5.10
Repaired OS FS permissions, dug around in the system logs. Dug into the Activity Monitor to find any rouge processes using IO, mem or CPU
Moved the virus AND the Balance Interface to different USB slots using onboard laptop ports each time as well as a powered USB hub [Belkin USB 2 5 PORT]
Reinstalled Virus 5.08 firmware
Running cubase as a brand new user.
Reinstalled Plugins ETC

My Thoughts

  1. Cubase and core 2 audio are cpu bound [however this is not evident from the activity monitor]
  2. The onboard display GPU [AMD Radeon HD 6750M] is not capable of driving the monitor and the LCD display and the graphics offload to the CPU is causing the problem
  3. The balance audio interface is broken [however, the audio problems only appear in cubase]
  4. Cubase and/or core 2 audio are not playing nicely together = bug in cubase

By the way - all other audio programs [such as reason 7 with lots and lots of tracks or adobe auction] work perfectly.

Sorry for such a long post, I wanted to get all my bases covered before I posted here.

Before I splash on MacPro - has anyone got any other suggestions on things to look at or try - I really am stuck now and I want to make sure I am 150% certain it’s my hardware.

Thanks in advance

I read the list of things you have done and did not see, “Increasing Buffer size” in Device Setup>

Try setting your buffer @ 512 :slight_smile:

Apologies - the buffer on the VST device is already 512 - making it lower does make the problem significantly worse. Increasing it causes cubase to complain that the value is too high.

What exactly does that error message say?

I am not with my MBP at the moment. However, the error message says something similar to “the buffer setting is too high, try setting it to 512 bytes or lower” If I increase it over 512 bytes in the device setup control panel for the interface in cubase. Dropping the latency under 512 results in almost no audio at all but with random clicks and pops. I will open a case with propellerheads as it may be that that the balance audio interface is faulty.

Some things to consider when problem solving- Go back to basics!

  1. Physically disconnect your audio interface, MIDI controller, etc from your computer.
  2. Open a new Empty template using the Mac OSX built-in Sound for output.
  3. Load audio and MIDI loops from Media Bay. Listen with headphones. Change the I/O buffer size (large to small). Any problems?
  4. Next, hook up your MIDI controller. Create an instrument track, record some MIDI. Any Problems?
  5. Hook up your interface. Listen to playback. Add more audio and MIDI. Alter the I/O buffer size. Listen. Problems?
  6. Etc.

No issues here with a 2010 MBP, 8 GB RAM OSX 10.9.2 running C7.5.1

I hope you can isolate the issue.
Cheers.

A quick update - I tried the things frog mentioned which where useful however [thanks!] the problem still exists [even with the onboard audio card] and I am still having major issues with OSX 10.9.2 and 7.5.20 - I’ve created a video of the problem here: http://youtu.be/iX82HxpJxqM

I’ve a call open with the Steinberg techs to see if they can suggest a solution - It’s definitely cubase related IMO as reason 7 works rock solid with no glitches at all, I really am stuck and cubase is currently unusable. :frowning:

Some say that most issues are caused by third party plugins. Are you using third party plugins with cubase? Maybe you should go to plugin information and uncheck all non Steinberg but keep Voxengo which comes with it and test again…

As you can see in my sig i have a similar setup.
Really no problems at all. Even my Macbook isn’t the latest. I can run lots of tracks and VSTI’s.
Things get a bit clumsy if i am using the 32Bit Bridge. This needs to be avoided!
Of course, latency should be set at 512 or higher if the projects become bigger…

And, get rid of plugins that you don’t really need. I have a sleek pluginfolder.
Only the good and reliable stuff remains in there. Be sure you have the latest versions.

Goog luck in hunting down your conflicts.

Regards,
Paul

Well – I have spent another day testing . I started a fresh with a simple one track project and my system was rock solid. I then started laying effects/EQ ETC onto this one track and again all was good.
I also started purely with 3 tracks directly driven from the Virus Ti Polar [IE no processing required] and the load on my system was very minimal.
I increased the VST track count gradually one by one until I hit about 5 extra tracks playing a combination of padshop and halion strings and synth sweeps – I soon started to get very slight artefacts in the audio.
Finally I added a bunch of mastering FX to the stereo out channel and this just brought my DAW to it’s knees and the audio was corrupting very badly. So I started to remove things from the signal path one by one and eventually I got a rock solid audio output.
I then ramped up the signal path again back to the point where the audio was once again corrupting very badly.

Then I had a a ‘eureka’ moment – I froze all the primary CPU requiring VST instruments and tracks and played the ‘stress’ project again. The audio played without a glitch!

So - I’ve come to the conclusion that even though my system seems reasonably spec’d [2.3GHZ Core i7m 8GB mem, SSD ETC] - I think it’s just not capable of running lots of VST tracks/FX/EQ with cubase 7.5.2 and my selection of VST’s

What I find most strange is that the VST performance meter is MAX’ing out [especially the real time peak] yet the Apple Activity Monitor is reporting that my system is 60% idle. There is a part of me that thinks the issue is related to poor graphics performance [perhaps with the discreet GPU not being able to cope with all the windows and the high resolution of my monitor [27” 2560x1440] and having to drive the laptop display as well] - But I have not been able to prove this – I have iStat menu’s installed but these just confuse this issue more as they report the system is not struggling.

Anyway, I don’t think there is much more that I can do with this. It’s time for a tech refresh :sunglasses:

Thanks to everyone who took the time to respond.

Are you using an external haddrive for sample streaming? it makes a big difference also disable spotlight on all your drives including your system.

sync24,

RdRm has brought a good point.
How many hard drives, internal and external are in your set up?
Ideally… Mac OSX and apps (Cubase) are on the internal drive, a separate drive for your sample libraries, and a third drive for your Cubase project folders and recorded audio. And then there’s the need for an additional drive for backups.

For now, even just having a second drive for samples or project folders may make a big difference.

If only one drive is being used, then the demands of running the OS and apps, reading samples and writing audio will exceed the capabilities of the read/write mechanism. More drives spreads outs the work load.

Good problem solving by the way.

Hi, I’m having the same issues here, similar configuration and so on. I found somewhere information that ASIO engine is hit more when using a lot of groups and fx channels, i tested that similar way that sync24 done, and there was no difference between sesion with no fx channels and groups, and the one with a lot of them, CPU at 50% and nothing more, when ASIO Meter all on red and audio glitching, skipping or even stopping… Anyone more with same issues?

My entire system is located on a 512MB OCZ Vertex SATA-III SSD [have checked it’s running at 6GB per/sec] . Black Magic reports > 400MB per sec across the board - I doubt I am getting IO bandwidth issues. I do have a NAS with a couple of iSCSI drives but these are for docs and are not used for the DAW and the NAS is link-aggregated with dual GB switch connections.

Dare I say that the cubase engine is not so efficient! :slight_smile:

I am going to follow up on the ASIO meter - and what Figiel said - worth a read up - and I will test turning off spot light as well to see if that helps - It’ll be a while before I can buy something new - Now the question will be CPU cycles over core counts!

I run huge sessions on my Machine up to 50 audio tracks and plenty of vsti’s and effects so it’s not a Cubase issue. Off course there are some vsti,s that can bring any sytem to its knees quickly like Diva and Omnisphere so it maybe a specific vsti you are using.

I have a mid-2010 MBP with similar specs as yours and I will echo the suggestions of others for using at least a second drive for your audio and samples. Fortunately, I was able to remove the internal DVD drive and use the stock 7200 platter internally for my audio/samples after installing an OWC SSD for my main drive. If you can do the same, take advantage of the fact that you can’t do that on the MBPs after 2012 due to the larger batteries. Also, VSTis, especially Padshop and Omnisphere are CPU killers on my system so I use them wisely and freeze or render to audio often.

I Have a MBP early 2011 2.7 I7 with 8 gigs of ram 2 internal drives one SSD and one Seagate hybrid and I’ve had the same problems as described above Ive tried everything and Cubase is pretty much useless. i don’t do a lot of midi stuff and 2 tracks and the ASIO spikes and audio cuts out. even at 1024 its horrid … i just put it up to the video card sharing the ram as it happens regardless of if my MBP is plugged into and extrenal monitor or not. i have an Apogee One and that feel on its face as well.

Have a look at this we page from SB about SSD CONFIGURATION…
A lot of our users have discovered the advantages of SSD drives. However we noticed that sometimes the SSDs are configured deficiently. A result could be that Cubase would play back stuttering audio- files or Cubase will shut down while you are loading big projects.

https://www.steinberg.net/en/support/knowledgebase_new/show_details/kb_show/ssd-configuration.html?tx_p77sbknowledgebase_pi1[product]=296

Why you assume that the problem might be the drive? There is no indication in performance meter that hdd might be overused. Yesterday I’ve done the test. I freezed all audio channels, got some more power, but mixing further I got to the point that cubase stucks… What OSX CPU meter shown was ~260% of usage :slight_smile: