MCU Functions Expanded in 7.5

Just the Bank buttons … everything else was an upgrade so it stayed the same :slight_smile:

I’m playing around with the new functions and I really love it! Especially the EQ control, much better now.

I’ve found one annoying thing in the channel strip control though: page 1 allows you to switch the modules on and off BUT this is not the same as bypassing the modules. So there’s no visual indication in Cubase at all to show if the module is on or off. I think it would make much more sense if the on/off function actually bypassed the module. As it is now, it can lead to confusion when a module is not bypassed and still turned off, with nothing to indicate that state.

Anyone having problems getting shift-smpte to activate the meters?
Just replaced my P&G MCU for a new ALPS one and it still doesn’t work.


Owen Sound Ontario?
from T.O. here

Question for MCU users:

To my knowledge Control+Tab is a windows command which makes the focus cycle through any open widows such as project page to mix console1 to an open VSTI to project page etc.

Unfortunately I can’t find any Key Command for this in Cubase, therefore it’s not possible to assign this to an assignable function button on the Mackie?

Am I overlooking something here? It would be nice to simply press an assignable button on the Mackie (or in my case Qcon Icon) to cycle through the open windows.

I would love to have a way to make my MCU bring to front what I’m tweaking (Plugin, Send ect).
When I’m on plugin mode, pressing the 1st knob on the left (where you choose what plugin slot you want to tweak) should bring the plugin to front!!
Please Steinberg put that in next update.

That could be quite handy. Even just a popup window with the EQ when you tweak it (digital console style) wound be great!

I’ve noticed something lately: Often when I load a project, I cannot control anything from the buttons on my MCU Pro. I need to sort of “wake it up” by touching one of the faders. I’m using two extenders, and touching the faders on any of them will wake them all up. The units receive data fine, but only start transmitting after the fader touch.

There are way too many factors involved unfortunately. I built a new computer at the same time as installing 7.5, and I also switched from WinXP to Win7, so any of these factors could cause it. But I’m wondering if anyone else is experiencing the same thing perhaps?

Same thing with me. 2 or 3 select buttons - then “play” twice.
It used to be worse.
Have no idea what causes it


When did you start noticing this?

I saw now that it’s the same in 6.5.5 (64 bit) so maybe it’s hardware or OS related rather than Cubase. Never had this problem with the previous computer. I could wake it up by moving the jog wheel though which I prefer to moving faders.

I’ve also had problems with the scribble script not loading correctly. I have to go to device setup and reset the affected unit to fix it. After that it works flawlessly.

The new fonctions are working with my MCU PRO, but if I use “shift” with the bank buttons it do NOT alternate between Band and Channel jumps :frowning:

This is not very important, but does anyone have the same problem or know a solution for that ?

+1 :sunglasses:

Yes. I have the same issue. Maybe someone has discovered a fix and can fill us in on how to get this working.


Didn’t get a chance to check it again in 751. Definitely works for me in 752. Pushing shift makes the bank buttons become channel ( or the other way around . . Not in front of it right now).

Using BCF2000 in Mackie mode here now. Works great!

Are there any “7.5-compatible” graphic overlays available somewhere - that you could print yourself?

So, I’m making graphic overlays for the BCF2000 in Mackie mode, but I need some help to finish them up:

I too discovered this just today totally by accident. I too wondered what it was even there for in earlier versions. I spent 8 hours reading through the manual and going over every old feature and seeing what has changed and what is new.

I really like shift with the Fader Groups and not updating the mixer display but the faders on the MCU. Kind of like Fader Groups on the Avid Icon. It seems that shift and group 8 is different than group 1 in that it doesn’t show you tracks that are part of the “Divide Track List” other than that I can’t tell a difference.

I too would love a way to globally save or import the Fader Groups.

Now, this is interesting… I was just shift-pressing around to find whatever was going on, and when pressing shift+fader bank button 3, Cubase freezes completely. Same with 4 and 5 I think. I then tried the same thing in a project with just 2-3 tracks - didn’t freeze. Hmmm…

Anyone else getting this?

I have not experience that with a large project. Shift+3 shows me my groups on the faders just fine with Fader Group button 3.

hello sorry for disturbing

I’ve been trying to save single and multiple track presets for use in another project. The track presets seem to be saved (they show up in the folder I put them in). But they won’t load on any project. Anyone else have this problem?