MCU losing touch with reality?

I have a Behringer X-Touch set up for MCU via USB using the Cubase (rather than Compatibility) mode. I don’t know if this behavior happens on Mackie MCUs as well or if it’s just the X-Touch.

I’ll be working away with everything working just fine, then at some random moment I’ll go to move a fader and it’ll snap back to where it was. At that point other faders start misbehaving in a similar manner and it’s basically over the rainbow. If I close and reopen the project, it returns to normal.

The behavior is very similar to what you’d see if you had fader automation but tried to move it manually, with the automation pushing it right back to where it should be. However, I don’t have any automation at all in this project. Nonetheless, I went through all tracks to visually verify that. I also verified that the X-Touch MIDI input and output in Device Manager is set to the X-Touch USB midi device. I have no other MIDI devices connected and verified that as well.

I’m running out of debugging ideas. Anyone encountered this sort of thing with MCU type devices and have suggestions on what I might be doing wrong?

I have had this happen with my Mackie units in the past, but not recently.

What I believe is happening is that Cubase is not sending feedback to the units (or somehow it’s getting held up) so they retain the last received position - thus snapping back to it.

I believe when this happened to me the fader in Cubase moved.

As I said, it hasn’t happened in a long time, but I believe I would try resetting the unit (reset button on Device menu), or if that didn’t work turning it off and then back on and THEN resetting it again. Sometimes pushing the reset button a few times.

I did notice one thing when I set up the Behringer unit for my friend, and that was that sometimes the faders did not register my touch. If they do not then no changes will be transmitted and the behavior you describe occurs.
That never happens with the Mackies.
Try touching the fader more deliberately with lots of skin and see if that helps.


Hey, Hugh.

Thanks, man. I forgot to mention but yes, when this happens the faders in Cubase move, but not the hardware unit, so it sounds like the same thing. Auto touch seems to be working fine, so I haven’t had any problems with that issue. I’ll try the reset suggestions you made tonight.

I also recall reading something either here or on the Behringer forums about USB MIDI being potentially problematic. If I recall correctly, something about the pipe getting choked up or something like that. If data is getting held up, perhaps that’s a factor.

Are you aware of the thing I’m talking about? Also, are you connected via USB or just regular MIDI cables? Don’t know if there is a performance difference or vulnerabilities to each scenario. I can switch to MIDI but I’ve gone USB just to have fewer cables, so trying not to fix it if it ain’t broke.

I’m connected USB to the Master unit and then MIDI from the Master unit to each of the 2 slaves (the Mackie has a built in 3 port interface).

Like I said, operation of my units has been flawless for a long time. Not sure what fixed it.

One other thing I forgot about - the kind of thing nobody suspects.
At one point I had a bad MIDI cable. Brand new, high quality, never abused.
But it was bad (intermittent, actually - even worse). Took me a while to suspect it.

So . . . check your cables.


I got bit by this exact thing myself just last week, so a very worthwhile suggestion. Hadn’t thought of validating the USB cable, or port for that matter.

I recently swapped mixers and completely gutted and rewired the studio. In one scenario with an outboard pre and compressor, I was getting a massive 60 cycle hum. Assuming it was related to something I’d done in the rewiring and probably an evil ground loop thing, I spent hours debugging, all to no avail.

Eventually I pulled the cables in the bay that were patching in the pre and compressor and noticed that one of the 1/4" cables was TS, not TRS. Corrected that, no more hum. Not a bad cable, but a cable problem nonetheless. Stupid, stupid, stupid.

It’s always the little things.

Forgot to ask, are you running the MCU in Cubase or Compatibility mode?

Cubase mode.

Much increased functionality that way . . .

Yep, that’s what I’m running as well.

So tonight I had time to spend the evening in the studio. And after several hours of waiting for the problem so I could try the reset stuff… nothing. Worked perfectly all night.

I suspect the TV repair man syndrome.

This happens when friends are having issues with their systems.
I walk in the room and everything works great.
They’re like . . “but, but . . .”

(After I leave the issue comes back)


By the way, I just noticed you’re in the ATL.
Same here.

Yep. I say ATL because it’s what people relate to but it’s actually Canton.

I like to think of it as the “suburban country.” Horses and cows down the road, deer sleeping in my back yard, but five minutes from 575 so I can have access to civilization (I’m a city boy by nature).

You in the metro?