Measure numbers... minus 2? [SOLVED]

Hi, dear Doricos.

I have updated Dorico to v. 4.3.30 and I have restarted my pc [notebook i7, 8 Gb, Win11].

I am working in a comparatively big file (an opera in Vocal Score, one act with 18 characters and 13 Chorus Voices -each with his/her staff-).
I have no issues with starting or loading, BUT I have found that, in the same system, the measure numbers for the first staff and the rest are not the same.

As you can see in the attached .png, there are a difference of 2 units between the piano and other vocal parts (the right number) and the first staff (“la prima donna”).

I have checked this with other staves as first in the system and they give me the right number.

This behavior started with this update, not before.

Thanks in advance for the always welcome suggestions!

Does the top staff have an individual time signature somewhere in your file?


No. Only the Piano part had for some bars a double time signature (Right: 3/4 ; Left: 6/8). All the others had the same (in those bars, 3/4).

Searching now the exact place where all begun :slight_smile:

As Derrek suggested, the top staff had a (mistaken) time signature change and from there the measure count was different for that staff. I have fixed it.

Thanks, Derrek. And cheers to the Team.