Measure numbers with Dotted Barlines

doing this in Dorico 4.

In Dorico 3.5 I had an issue with bar numbers when dividing compound meters using dotted lines. I looks like this file carried over the issue to Dorico 4 in that the system track (global bar numbers) is not displaying the correct bar numbers. Is there a way to get the global bar numbers to display the correct numbers? It looks like global bar numbers


is what’s used for rehearsal marks.

Would using an aggregate time signature instead work in your situation?

I tried but there is no option to have a different time signature for display – that would be great if I could just do 3/8+2/8+2/8+4/8 – but then just display 11/8. That would solve it - but I can’t figure out a way to do that. I wonder if there is some script or something I can run.

1 Like

Right, I see. Have you tried inputting these time signatures as local (e.g. by pressing Alt/Opt-Return to close the popover) to allow you to input local barlines (same method)? You might then be able to use the new Notation Option for using local/global bar numbers and set it to global – although I confess I’ve not tried that out myself for something like this.

I did try that - but it’s a multi staff piece — chamber orchestra – - in fact I’m having a bit of trouble getting one of the staffs to - not be local- not sure how to go back - thanks for looking at this with me Lillie! Do you know how to reverse a single staff time signature? - can’t seem to get the staff to reattach to all other staffs for time signatures

If you input a new, global time signature at a position where there isn’t a local time signature, that should bring the local staves “back” alongside the others.

it does that for the specific “New” measure for new global time signature - but later time signatures on other measures still seem to be stuck on “local only” in specific staves.

It might be easier if you can share the project so someone can take a look.

here ya go – as you can see, I can’t seem to get the time signature that I want – with dotted line divisions - displaying 11/8 --then ---- when I use the other method of just manually putting in the dotted lines - the measure numbers go wild.

I haven’t opened your project to look, I’m sorry to say, but if you’re running Dorico 4 then the new option on the Bar Numbers page of Notation Options to use the global bar sequence for bar numbering might just possibly maybe help (did I covert that in sufficient caveats?).

In Dorico 4 - It seems that I am unable to change the global bar numbers are reflected in the system track - those are the ones that are incorrect. You’ll see that in the file. I’m not sure how the global bar numbers got changed. And it’s not clear how to change them back. I’m sure I’m missing something here but I don’t know what it is. If you look at where bar 15 should be - it says measure 3 – and its seems impossible (on my end) to change it.

Lillie - I’m not sure if you have a moment to look at the file - but were bar number 15 should be - I am unable to change it from say measure 3. Any ideas on this?

also - thanks so much for looking at this Daniel!

Hi @dsj9 , you posted your reply with the project yesterday (Friday) afternoon in UK time where I am, and it’s now Saturday morning. Please offer some patience before bumping your thread, thanks!

1 Like

Thanks for your patience @dsj9 – I’ve taken a look.

If you essentially give all the 11/8 bars where you want to subdivide with dashed barlines local time signatures for all staves, and set the Notation Option Daniel mentioned earlier to use the “global” count, you should get the result you want. (Touch-wood)

Here’s your project back – to make it a bit quicker, I set up one bar of 11/8 with dashed barlines on the top staff, then Alt/Opt-clicked it onto the other staves. Then selected that bar across all staves (11/8 time sig and dashed barlines) to enable easy duplication of that setup to other relevant bars. The 12/8 time sigs are still global, just because then you only need to manage one time signature “item” in those bars!

I also took it upon myself to tweak your Title page master page so you’re using a custom paragraph style for those bits of text (makes them a bit more independent, rather than manually resized “Default text”), and assigned that to the first page as a page template change, removing the page override. I also replicated your local edit to the copyright size on the first page of music onto the corresponding First page template, so that’s a bit more safely preserved.

The playback template here is set to Silence, so the file size is smaller.

bar numbers time signautre SKYE music_LH.dorico (894.0 KB)