Mechanical Faders Not Moving With Midi CC

Hi Everyone,

I’m having an issue with my Icon Platform M+ and Cubase 9.5 Pro. It seems that the mechanical faders do not follow the midi CC data that is recorded in the Instrument track midi event. So how I have it setup now is that Faders 6-8 controll the Modulation (CC1), the Expression (CC11), and the Vibrato (CC21). It works perfectly where those faders controls those CC channels within a Kontakt library.
The issue comes when I play back the file, the mechanical faders do not follow the midi lane CC data.

I spoke with an Icon representative and he had this to say:
This is a common limitation users experience when they’re using a generic control surface with a custom mapping, which is caused by return MIDI messages.

The issue is that while you’ve mapped the message you’d like to control these parameters, the plugin and DAW are sending a return message to the controller that it is not mapped to expect the return message for.

Unfortunately there is no current way to map this return message using our iMap (though you may be able to use a MIDI translator to map this message). However we are investigating ways to make this mapping easier and more intuitive for users.

It may be possible for you to clear this message up within Cubase by also setting the MIDI learn parameter for Cubase along with the plugin and the faders, so they are all expecting the same messages.

Do any of you know if there is a way to get this to work in Cubase? Much appreciated for the help.



I was able to find a video where a guy used a script or something to send the midi back to the controller, but it’s for Reaper.

https://www.youtube.com/watch?v=ZO6eQt6L1KI



Regards,
Ben.


mod message: please don’t cross post to multiple subforums

Hi,

It’s a duplicate, isn’t it?

Indeed. I’ll close this one.