Media bay tempo align preview feature not working but works when audio drops in project

Am I missing something?

What needs to be specified in an audio file’s metadata in order for Cubase to correctly beat align it to a project tempo?

Reaper works flawlessly on this action by comparison. Same files (without tempo info).

I have already added tempo to the metadata since, but Cubase will not alter the tempo to match the project.

Is anyone a frequent user of media bay tempo/beat align preview feature with non-drum audio?

Is there any reason why Cubase will not align the tempo for such material? Or is it just on my end?

As mentioned reaper aligns the tempo for the same material in its media bay preview flawlessly.

@Ben_at_Steinberg @John_at_Steinberg @dspreadbury
Sorry but due to a lack of Steinberg support line I need to tag you folks.

Can you confirm whether audio material without clear hitpoints are supposed to be successfully ‘beat aligned’ when previewing from Cubase’s media bay?

Over here, only drum content is able to be matched to various tempos.

Is there anything I need to do in the metadata of more random/melodic audio so that Cubase can align it to any tempo when previewing in Media Bay?

You need to make sure that in the Pool Window the Audio File’s Tempo is correctly set to whatever it was when the file was created. You also Enable Musical Mode for the file, which will allow it to stretch & shrink to accommodate Tempo changes.

Here’s a more detailed explanation

How Musical Mode and Linear/Musical Timebase Interact

1 Like

Can you attach here few of those loops that won’t beat align?

Are you “topping and tailing” your files before opening them in the Mediabay to ensure the start and end points are correct?

I try and “tempo correct” audio outside of Cubase - I’ve never found it that good at time-stretching/shrinking especially with audio that doesn’t have well-defined hitpoints.
ProTools etc much better at this in my experience. Not used Reaper. Yet.

Thanks man but I think you’re referring to project events, whereas I’m talking about previewing audio from the media bay using its beat align feature.

1 Like

Reaper is flawless, without having to do anything to the metadata; but to answer it yes these are perfect length audio events and I’ve even added the original tempo in its metadata.
I think it’s a case of unclear hitpoints where Cubase struggles.

OK re preview but what happens when you drag and drop them FROM the mediabay into a track in Cubase? Are they aligned correctly with the BPM then?

Also it’s worth noting that Cubase still has issues playing REX files in the mediabay. For example whenever I try and preview a REX file it plays at half-speed. This is with the beat-align feature switched on as well so don’t quite know what’s going on there.

PS: I’ll have to try Reaper at some point although having used Cubase for nearly 30 years it’s difficult to change when you’re so used to the workflow pattern.

1 Like

Thank you for asking that, because I should’ve tried it before.

Yes, when I import the audio from the mediabay into an audio track in Cubase, it is perfectly beat-aligned!!

This means Cubase has enough smarts to deal with beat-matching such material.

But it makes the case of why it doesn’t get beat-aligned when previewing from the media bay all the more mysterious.

Glad it worked OK in the project but obviously it is quite frustrating when you’re going through hundreds of audio loops searching for the perfect sound and it doesn’t preview properly. Sort of defeats the point really doesn’t it?

In my Spectrasonics Stylus RMX VST it will auto-preview the file as you play the project. At the correct BPM. I wish Cubase could do this.

1 Like

Absolutely strange and yes frustrating.

It would help a lot of users if they could get this right.
In my experience, it is buggy and needs fixing. I think I’ll log it as a bug.

Also would be helpful to point out which loop(s) exactly won’t sync out of milion²³ loops out there. If there is off sync with some file from cubase factory library let as know which one exactly.

it’s not from the stock loops, it’s my own material.

Are you sure your files contain the bpm metadata?

yes, and the strange thing as I’ve said above is that dropping the file into the project it aligns itself perfectly. Just cannot get it (and others) to preview from within the media bay at the correct tempo alignment.

finally had a read of your thread, thanks for the info. The last paragraph might be the cause of my woes. I’ll play around with it. Namely, setting the correct tempo first, although I think I’ve done that.

As you mentioned in your post Cubase ‘on occasion fails’ to correct the tempo for various reasons, maybe I have to accept the files I’m previewing are not set up properly – but I keep coming back to when dropping it in the project there is no such issue!

Anyone solved this issue please?