Mediabay not loading Halion Sonic 3 new instruments that are in mediabay

Hi Folks,

I have upgraded to Halion Sonic 3 with Cubase 9.5.10 but now have a problem with mediabay not loading the instruments. Hoping someone can help.
I have tried a reinstall but its making no difference to mediabay. HS3 itself is working fine.

The issue:
When using MediaBay to load an instrument based on HalionSonic (e.g. Skylab - Alone and Lost) the the instrument is found in Mediabay but:
a) Doesn’t preview, and
b) You cannot create an instrument track

If you load HS3 manually to a track and load this sound using HS3 it works

Now, if I grab a Halion Sonic Factory Library Sound “Alone perc” - everything works as expected from Mediabay

I also noticed that the Mediabay in the Right Zone, which shows the different pictures of instruments doesn’t show any of the NEW HS3 instruments (Skylab, Anima, etc) but does show all the HS2 ones (Aurion, Haliotron).

Last thing I noticed, the Attritbute Inspector under Path has a different vstsound:\ for the newer instruments.

I have used the Halion Media Manager to move the instruments to a different drive but this has made no difference, even after reinstalling HS3 its still broken.

I’m guessing I need to somehow reset mediabay but can’t find a button to do so. I tried Rescan and it certainly rescanned when I reinstalled (I had to wait for it), but alas the behaviour is still the same.

Suggestions anyone?

I completely removed Halion Sonic and all content using the uninstaller, went back to the hard disk and removed all traces I could find that were left over. Reinstalled it completely.

Problem still persists.

Mediabay, under the VST Sounds folder in the file area shows all the HSSE, HSO and Halion Sonic 3 presets. Only the HSSE and Halion Symphonic Orchestra presets will preview and load into the project from Mediabay. ANY of the Halion Sonic 3 content, be it Combis, Skylab etc will NOT preview or Load.
I tried rescanning the VST Sound skylab folder - no change.
I unchecked the Skylab folder and said remove from mediabay database, it removed.
I re-checked the Skylab folder and mediabay rescanned - BUT NO SKYLAB CONTENT

I cannot figure out where the VST Sound information is coming from and why this cannot index. Further up file tree in media bay, where actual folder locations on the physical hard disk are shown I made sure all the VST sound areas are checked. This appears to have no relation at all to the VST Sound at the bottom of the Mediabay.

How the heck does this thing work and why can’t a reinstall of HS3 fix it?

On the bright side HS 3 can see all of its library content, its just Cubase’s Mediabay that is stuff.

Any suggestions?


If you should have this problem the only way I could fix it was to do clean install of Cubase and Halion Sonic:

  1. Uninstall Cubase,and all associated programs and content that come with it
  2. Uninstall Halion Sonic
  3. Go into C:/Users//AppData/Roaming/Steinberg - and delete anything associated with Cubase components in 1 and Halion Sonic (noting this directory contains all your user preferences as well so don’t just randomly delete, either take care or perform a backup - in fact just perform a backup in case you miss something)
  4. Check for any left over Halion related .vstsound files left over from the Uninstall - I had left over copies of HS files in several locations. Windows Search is your friend
  5. Reinstall Cubase and Halion Sonic 3

My guess, the problem came about from using a Cubase UPGRADE install rather than a Full installer, combined with Halion Sonic upgrading over the top of the HS2 installation. Given the number of left over files from the uninstall process I had to remove the installer clearly just can’t keep up with historical uipdate process scattered across my machine.