Mediabay playing not in sync the audio files?

Hello!
I hope it was not asked before, it’s my first post and I can’t find anything on this subject:

So I jumped from Cubase 3 to 7.5 recently and trying to make beats again.
In C3, I used to put an audio track or sample into a channel.
Then i took the cut tool to separate my .wav in several loops of 4 or 8 bars.
In C3 I used to select a single loop in the track and apply audio>insert effect or audio> process to achieve different results on each loops separately.

Now on C7.5 when I simply want to do the same, apply an audio>insert effect or audio> process (reverse per example) I see my entire track containing the loops having the effect applied ! :frowning:

How can I change this behavior and get the same way C3 was working?

Any ideas?
:wink:
Thanks by advance!

Greetings

Dj Zen.

Does it ask if you want to make a new version?

No! But finally I found the option…It’s on the audio editing preferences! Thanks :slight_smile:

BTW: another quick question: how to play ramdom .wav samples (not acidized, not previously checked with a loop editor) in Mediabay in sync with the project I have?
Let’s say I have a 125Bpm project, open Mediabay and browse my samples…When i click play and click on some samples, it’s never playing in sync with the 125bpm…they are keeping their original bpm (that is not shown most of the time) - anything I missed?

thanks!! :slight_smile: