Mediabay preview REX files at project tempo still not fixed

This has been broken/not working since forever - can someone please tell me if it has been fixed in version 8?


this functionality is still missing.

So, now the Mediabay has received some love in the 8.5 update, can someone please confirm that REX files previewed there will now play at the project tempo?

Nope ,they still don’t play in sync

Pffft. Why am I not surprised by this? Steiny, you are truly woeful. :frowning:

What you need to do is to edit the tempo of the file in the mediabay so it reflects the original bpm of the rex file…

  • then it will work…
    (Select multiple files for batch bpm editing)

Its a workaround… (metadata of rex has no bpm values set)

In my mediabay all REX files have the correct tempo already listed, it cannot be edited.

Maybe it’s because I’m still on v6.5 and this workaround only works in later versions(?)

Thanks anyway.

Not at computer, but, bottom left area in media bay, there is a little hidden menu…

  • check : allow editing in media bay
    Then you can edit the file properties from mediabay…

Ah, 6.5… Dont remember how it was in that one… - nevertheless, give this a shot:
Enable editing in mediabay, re-enter the bpm of the file

Hope it helps…

Thanks ggc,

I found the menu, and I enabled the setting that allows me to edit tempo.
Unfortunately it seems to have had no effect… no matter what I set the loop tempo at, MB previewer plays it at the same old speed. Even with extreme tempo values, the result is the same.
(I have set “follow tempo” to “yes” for the loop, and “align beats to project” is enabled in the previewer. I have also tried entering different values for “bars & beats”, without effect).

It’s such a basic, basic piece of functionality, I fail to see why they won’t make it work.
(One workaround for them would be to render the file to a temporary wav, then stretch that for preview purposes. It would take approximately one day to code, including a long lunch) :nerd:

I can’t believe this glaring omission still exists. No other DAW I know of has the issue.

I always end up just having to delete any REX files so they don’t appear in MediaBay and annoy me. It would be nice not to have to and have the option of using them without having to jump through hoops.

Not a bug (for the 100th time)

It is purely a licensing thing against Propellerhead (who owns the REX idea)

As in Steinberg are too cheap to pay the license? I assume other DAWs pay the license since they can preview REX at project tempo?

Sad this is still not fixed and yet another reason for me not to update.

Roll on C9 :unamused:

Sounds like apologist nonsense from someone who never uses REX files.

Cubase stretches the files correctly when you drag them into a project, it’s just that the preview in MediaBay is at the wrong tempo. They will play in the previewer, just not at the right tempo.

So your imaginary license conditions must allow for Cubase to use REX files in projects, and also in the previewer but ONLY if the tempo is wrong? ? What kind of licensing terms are those :question:

The fact is that Cubase CAN read and play the file format, as is proved when you drag a REX file into your project…
Cubase creates an audio part for it containing the individual audio slices correctly aligned to project tempo. The REX loop will sound fine in your project, just not in the MB previewer.

Additionally, Steinberg has never confirmed one way or the other that it is a licensing issue.

Do you have any actual evidence, or is it just your gut feeling?

Yeah, still not working, still iritating

To whom do I apologize to ? it irritates the $hit out of me, too. for years (there are alternatives, though)

I don’t know how old are you, but I use REX since its inception (late 90’s). how about you ?..

I think (THINK) that was the problem.
When you step out of your fury and actually THINK… do you REALLY think that it is a “bug” that they could not overcome ? since Mediabay’s inception ?? really ???

There is a reason for mediabay’s inability to play REX at project tempo. “a bug” is probably not of the possible reasons.

As far as I can tell supporting Rex files preview in MB as been on the list for years.
We should bug this forum till they hear us.

… They haven’t listen to a single suggestion that I have posted through the years… So let’s see

So, by chance, i actually used a rex file which was stashed in my “Legacy” sounds…
-gotto love the good ol old school sound archive;) (heart, smiley face)

Ok, yeah, mediabay doesnt play them in line with the project or tempo… But this didnt bother me much during this session as i imported it and all was fine…- still, i see valid points in that mediabay should be able to handle them…

The thing that bugged me was- clicks and pops when imported…

I assume (yes, assume) that it has to do with the rex shared library?

  • i saw that logic/mac received a newer 64bit shared library from the propellers -but no newer cubase/windows one available:/ - is ours up to date?
    Could it be that we are using a older 32bit library in our 64bit cubase?

Orrr, Could someone please tell me something about the clicks n pops on (some,not all) overlays?
(Some fade setting somewhere or so?)

Thanks and have a good weekend:)

P.s.- old Fecker- i was refering acid in my earlier posts… sry for the confusion…lol

Pls never give up asking for REX support.
50% of my recourse library is still Rex.
Common Steinberg :open_mouth:

Must have been in the 90’ I last used any Rex file, are these still relevant now ?
Well if you have a big Rex library then yes, I just don’t see any new libraries out there in Rex format, but I could have been looking in the wrong places.
I know there is a Rex to wav batch converter, but only for Mac afaik