Melodyne Editor 4 showing up late on inserts

I have a couple of issues, though need to get this one fixed as an emergency asap. Please see this video https://www.dropbox.com/s/3rlmfa66mwsufpp/VID_20200422_222335.mp4?dl=0 and let me know if there is anything I need to do to stop this delay from happening when using Melodyne, which is routed through a vocal insert. It plays perfectly, though visually it is clearly delayed and as you can see, 2 seconds ish.
I tried updating and reinstalling Melodyne4 Editor and still the same issue is present in Cubase 10 and 10.5. Spoke with Celemony about it and they say it’s something Steinberg should be able to help with and may be related to ARA, which in this case i am not using.
Not sure how the tech support at Steinberg is doing, though there’s a lag… Hopefully someone here can help in the meantime to get this mystery repaired

Hi,

Why you are not using ARA, please?

In any case, if you use it as a plug-in, the delay of the plug-in should be compensate, by Cubase. But the plug-in has to provide the correct delay time.

In the MixConsole open the Setup Windows Layout and enable Channel Latency. Here you should see the cumulative latency of all plug-ins on the particular channel. Is the value meaningful?

I actually rolled back to a previous version of Melodyne 4 and found there’s now no latency. However, the recorded audio in Melodyne does not stop exactly where it is released, which leave a silence where there should be Cubase audio. Ideally would want the latest version of Melodyne.
Reason for using Melodyne as an insert is because there are lots of cuts between vocal takes. ARA is quite new to me and am loving it with Vocalign

Hi,

Then it seems to be more on Melodyne side, for me.

If you have lots of cuts, I would recommend to Bounce the Vocal first and then use Melodyne as ARA.