merging midi parts onto one track

I’ve done this a thousand times in the past. I have several tracks set to the same midi channel, each with a midi part or two. Sometimes the midi part of one track overlaps the midi part of a another track. But events from both parts/tracks get played.

What I’m used to doing is -dragging parts from one track onto another, then using the glue tool to merge them into one track/part that plays all events.

However, now when I do that, where a blank section of one part overlaps events in another part, those events are “hidden” and no longer play once the parts are on the same track.

Have I unknowingly changed a setting somewhere? How do I get the parts on the same track to all play back their events regardless of overlap?


Just giving this a bump… I haven’t been able to figure it out yet.


Have you tried using “Bounce MIDI” on the track after you have moved all the parts onto the destination track? It should combine ALL parts into one part, keeping everything.
Sorry, I can’t answer the question about what is different than before.

Hmm… not sure how that’s different than just using the glue tool to glue the parts together (which does not work… the obscured overlap areas do not show up), but it’s certainly worth a try. I’ll give it a go when I get to the computer.

I did a test on my system using the glue tool as you describe. MIDI events that were inside the original part(s) boundaries were always kept after the glue process. I did find one peculiarity. MIDI events that are OUTSIDE the original part boundaries sometimes appear after the glue and sometimes not. I experimented for a couple of minutes but could not quite figure out the pattern on this behavior. I also could not find a preference concerning this. As far as I can tell, MIDI Bounce does the same thing, it just may be faster if dealing with many smaller parts. I am not sure if that is exactly what you want, but it may simplify things.

As far as the behavior you are experiencing with the glue, if you gave a specific example (i.e. which part occurs first in time, which is in front or behind, where you click with the glue tool, if there are MIDI events outside of the part boundary, etc.), I can test it here and see if I get the same behavior.

Indeed, if you can provide a simple step-by-step method from an empty project of repeating the problem then we can confirm the prob the mods will take note.

I’ve noticed the ‘outside’ midi notes problem before in Cb5, but I haven’t used Cb6 much for midi yet.


The basic problem is that when a second midi part is placed on a track, if they overlap then the part “on top” wins, and the part below is muted during the overlap.

I tried moving the parts onto the same track, selecting the parts, and then “Bounce Midi”. This still resulted in the muting behavior.

“Merge in loop” can work, but you have to be careful since it will merge anything active… so it’s a little fiddly.

To repeat:

  • On track 1, create a midi part that starts at bar 1 and goes to bar 4. Put some midi notes throughout it.

  • On track 2, same midi instrument/channel, create a part that goes from bar 2 to bar 5. Put some notes in it, but leave bar 2 empty (just to make the illustration clear).

  • Note that midi material from both parts plays simultaneously.

  • -drag the part from track 2 to track 1. ( just to maintain alignment… snap works too)

  • So now, part 1 starts earlier in time, part 2 is “in front” or “on top”.

  • Now note that wherever track 2 overlaps track 1, the midi material on track 1 is no longer played.

  • gluing the parts together by clicking the glue tool on part 1 does not “bring back” the hidden material on track/part 1

  • the only events from part 1 that remain are those that are not where part 2 covered them up

This is not how it used to work.

One other thing I noticed: when I drag the part from track 2 to track 1 and “view lanes”, I see it put it on the same lane within track 1. If I do “view lanes” on track 1 and drag the new track/part 2 off of lane 1 onto lane 2, the part on lane 1 ends where the overlaying part started. It’s like by putting it on top of part 1, it erased everything underneath, including part boundaries.


Interesting. When I do the steps as you describe, All the notes play at all times. I think the difference is that Cubase always has mine on two different lanes from the start. It won’t even let me put them on the same lane. What version are you using? 6.0.4 here. I believe they changed some of the lane handling features recently.
I think your answer lies in the lane handling/comping behavior which I am not very familiar with.

I’m unable to test this for you until the weekend, but I suspect the lane handling too. I’m pretty unhappy with the new lane ‘features’ because they’ve reduced the flexibility and introduced too many rules into what was a simple and flexible system. When I’m working with Midi I’m very often doing the things that you’re doing and it’s just not as easy any more.


Jaslan, that’s definitely not what I see. There is no overlap crosshatch, and the notes in the overlap area for the “bottom” part are not visible.

I agree, it seems like some sort of lane issue. I wouldn’t begin to know how to make the drag put it on a new lane instead of the existing lane. I’m still at 6.0 and have been holding off due to having a number of in-progress projects, but I guess it’s time to upgrade and see if that helps.


merge function works if
the parts are selected in the arrange window
the merged part will appear as if by no reason overlapping the first highest midi track in the session
duplicate the merged midi track channel for the same settings
delete the original parts of the first
move the duplicated snapped merged part onto the empty track
delete other midi tracks not required
simples, not