Messed up MIDI timing when recording

After reformatting my PC and upgrade to Cubase 8 I have the weirdest MIDI issue.
Spent 8 hours trying to solve this today but still stuck. Hopefully someone here can help.

When recording midi, the timing is way off. It´s is severely off. Not like these other issues with late/early recordings, but the performance simply collapses into a big mess. The playback when recording sounds good but the notation of the midi and the playback afterwards is a mess. I´m running a fairly big filmscoring template and I have to add that the problem does not occur in an empty project.
I did remove all VE-Pro instances in my session to see if it was CPU related but that did´nt help.
The weird thing is that retrospective recording works fine. So the midi data cubase receives must be in good condition? It´s with the notation of the recorded material it all becomes messy.

Tried 3 different MIDI interfaces. MIDIMANMidiSport, The USB from my Doepfer LMK and a MOTU Fastlane USB.
Same issue with all of them.

I would very much appreciate any ideas & help to get this solved.

ADK Audio Computer
Win 7 Pro
Intel(R) Core™i7-3930K CPU@3.20GHz 3.30GHZ
64 GB Ram

Cubase 8.0.20. Build 468


see this Steinberg knowledge base, please. I think, this is the same issue, you described.

Hi Martin,

Thank you for the link.
I had alrerady tried moving the “Midi port enable” files without success, but had another take on it now to make sure I got it right. I´m getting the same result no matter if I move them.
Not sure if the none emulated midi drivers are supposed to work or not?
Am I supposed to be able to actually use these?


To be honest, I’m not a Windows user. But when I solved this on customer’s computers, I tried to move these files Over these folde ra, until it worked. :wink: So sometimes, the user was using the emulated driver, and sometimes the “original” one, depending on the result.

Hi Martin,

Just so that I understand this correctly. It´s a little confusing the way that article is explained.
When those files are moved up and out of the “midi port enable” folder, we take them out of work right?
For them to do their job they have to be in the “midi port enable” folder?
1 of the files is a filter making so you can´t see the drives Cubase assumes do not work.
The other file enables the Windows MIDI drivers so you can actually use them.
Correct so far?
I´ve been moving them in and out of that folder trying all sorts of combinations. Both out, either one of the out etc… I did get the Windows MIDI drivers to work at some point but ONLY IN A CLEAN session.
This all gets quite confusing. I haven´t been able to make the Windows MIDI drivers to work in my big template.



Yes, you are right. It should works, like this.

Interesting, with your template. Are you able to see these MIDI ports 9which are currently out of the folder) in the tracks of the template, or directly in the Devices > Device Setup window, if you are using the template?

Hi Martin,

Yes I can see them all in the Midi Device Setup but they won´t produce any midi.
No sound and nothing recorded when I select them.


interesting, you shouldn’t see them in the list in this case.

Could you try to delete your Port Setup.xml file from the Preferences folder, to make the MIDI Devices list fresh, please?

Hi Martin,

Did the moving of files again now testing both in my big template and in an empty session.
My findings were the same for both and the problem persists in all combinations for the template session.
Empty session is working as it should.

FILES REMOVED from “Midi port Enable folder”:

Ignoreportfilter removed: I see all drivers, but the Emulated drivers do not work.

Both Files removed: I see all drivers, but the Emulated drivers do not work.

Only Enableemulated removed: Emulated drivers only, and they work

Also tried switching the timestamp setting. It performs slightly better with them on but the main problem with stuck notes, midi being seriosly and unconsistently off is the same.

I will try deleting the prefs now.

I also have to add that I am for the first time experiencing a kontakt failure message saying: “A sample has dissapeared. Make sure all external drives are connected”. I´ve never seen this before I did the clean install. It´s not the same as the samples missing box you get when samples has been moved etc. It´s also not telling me which sample it is refering to.
Both Cubase and VE-pro can freeze up and crash when this happens. I´ve seen it like 5 times a day.
Can these issues be related?
I also installed new SSD´s when I did the reinstall of my system.


I´ve now tried deleting all prefs but it did´nt make any difference.

Been trying to solve this continously for the last 2 days and I´m beginning to loose it.
Any suggestions is most welcome.


I’m sorry, I have no more idea. But if you mentioned other issues, I’m afraid, it’s maybe on the system level.

Thanks for all your suggestions Martin.
You seem like an experienced guy. When you say system level are you thinking about my hard drives in particular?
The hardware PC(motherboard etc) has been functioning excellent with Cubase 7.5 and my old drives.


In the very 1st sentence, you wrote “After reformatting my PC…”. So I’m thinking about some system (Windows) issue. Do you still have Cubase 7.5, on your system? Could you try it in Cubase 7.5, please? Does it work here?

Would it be possible to recover your Windows system, before the changes, you did?


Today I´ve had a long session working on this.
I found my original Cubase 6 discs. Uninstalled Cubase 8.
Installed cubase 6. I open my session. Same session I´ve been having trouble with.

It opens but before I get to try the Midi recording to see if the issue was cured, cubase crashes when trying to switch to the sound interface I use from the default generic drivers.
I restart the machine and have another go. This time I switch interfaces before I load the big template.

Now Cubase hangs when loading a specific instrument in the template. Heavyocity Damage.
I give it time cause it´s stuck on loading. Realise after a while it´s not going anywhere.
I did this a number of times. Same crash on loading that instance every time.
I uninstall Cubase 6 and download Cubase 7 from the Steinberg site.
I get the exact same behaviour. Never got it to open the session.

Finally I´m thinking, okay let´s go back to Cubase 8. Although it did have the midi timing issue which now seems secondary, at least it worked when opening this exact session yesterday.

I uninstall cubase 7 and Reinstall Cubase 8. Same knuf thing happens. It´s stuck on the VE-Pro instance containing the Heavyocity Damage Drums.
It´s very strange cause I´ve never had any weird behaviour from this library/instrument before.
Nor has it been updated or changed during my reformat.
I´ve midi learned it some things that I now control from my Peavey 1600 controller, but that´s it.

So here I am now even struggling to open the sessions I opened fine yesterday.

Strange? For some time there I now could´nt even open Cubase at all. It crashed on startup.
I read about 2 of the Steinberg synths causing problems.
Uninstalled these and now it opens up but still won´t load my session.

Thinking again about the Kontakt message I´ve seen lately
“a sample has disappeared, make sure all external drives are connected”. Can this be connected to this?

I did expand my hard drives with 1 additional 1GB SSD disc with this install.
Can it be the motherboard is not providing enough power to take care of them all?
It´s 5 discs. SSD System 500GB, 2 SSD 1TB sample discs, 1 SSD 500GB sample disc & a regular 1TB audio disc.

If I´ve had dropouts from one of the discs and then saved my VE-pro meta-frame with potentially this sample missing.
Is it possible it´s now loading the metaframe without these missing samples every time?
I mean, since it was disappeared when I saved it.
Don´t know. Maybe someone with great knowledge of VE-pro´s structure can share some insight.

I tried manipulating the metaframe, hiding the samples of the Damage Drums etc so that it loads them again.
Changed it´s name etc. But the Cubase session is saved containing all VE-pro information embedded.
I cannot delete this instrument in VE-pro and open the session without cubase reverting my changes back to “how it was when saved” on every load.

Does anyone know if it´s possible to open a Cubase file with embedded VE-Pro info without it actually loading any VE-Pro instances? If I could get into the template and delete the suspected troublemakers and save as a new version it would be great.

Some serious frustration going on here now. With deadlines coming up also it´s getting serious.

If anyone has any ideas/suggestions they are very welcome.
Also, if anyone knows a great tech that does team viewer sessions please let me know.
Waiting for Steinberg techs to reply. It´s been a week now. Hopeful some Steinberg techs also will chime in here.


To be honest I did not completely read through all of the posts but did you try opening one of the .bak project files. Maybe your original .cpr project file is somehow corrupted. Worth a try I guess.

Also… Just thunk of this one. Is CB and all of your associated to run with it set to “run as administrator”. When formatting and reinstalling stuff this sometimes gets overlooked.

Regards :sunglasses:


I haven´t thought about the possibility of .bak project files not being corrupted even though the original is.
Do you know this? I don´t know what makes a file corrupted.
If that´s the case there´s no reasoning in that all my other versions of the session behaves “corrupted”.
I haven´t tried the .bak files. Will certainly try that.

Also, I have no idea if it is set to run as administrator. I haven´t touched it. If it´s not run in that mode by default and I have to manually set it, I guess it´s not being run as admin.
Will try this also.

Thanks allot for suggestions.

Finally I´m getting somewhere with this. The tech at ADK audio computers discovered something had gone very wrong in the BIOS settings during the clean install.
Going way back I´m now starting over with a new clean install.
The computer has not been working properly during these last 2 weeks.
Hopefully this is the cause of all the issues, including the midi timing I originally struggled with.
I´ll report my findings in a couple of days.

I have been going on for a week with this. Done a complete reinstall for the second time. I am still experiencing the issues with cubase crashing all the time, midi timing way off and freezes on loading of sessions.

Just now finished a session of 24 hour continous trial and error. I have deadlines next week and I cant work.

Still getting that new error message from kontakt that I have never seen before. “a sample has disappeared, make sure all external drives are connected”. It doesnt say anything about which sample or anything more.
No options in the box.
What Ive found is that this usually happens at the same time as cubase crashes, wont open up etc.
This just has to be related to all of this.
Maybe my SSD drives are not getting enough power or something, causing it to briefly drop out.

I am very tired and Im not getting anywhere after 2 full reinstalls.
Anyone else seeing this kontakt error? Not much to find when googling it.
What does it mean?