Meta data bug on Mac OSX finder

I just noticed that even though I have no meta data entered in, when I play a file in the OSX finder is gives me an artist name and info that I worked with back in November. I’ve done everything I can do to clear all fields but no matter what, when I render to wav files from the montage, this particular artist info is always with the file in Mac OSX finder, even on other computers.

When I bring the file into iTunes however, it sees no artist meta data.

Am I doing something wrong or is it a possible bug?


Are you seeing this data also from within WaveLab, in the MetaData window?

Do you mean the MetaData window within the render page?

If so, I see nothing in there and have tried to select remove many times.

Is there another way to check?

No, I mean the Meta Data Tool window, in the Audio File workspace.

Ah, it does show up there with the old undesired info, is there a field in the montage or render page that I’m missing or not understanding?


I just doubled checked, and all the MetaData looks clear in the Attributes field in the render window.

I have “What to render” selected as Regions>Tracks and “Create named file(s)” is checked.

The file name is always correct, but I can’t seem to get rid of the MetaData from a project done in December.

And again, the MetaData doesn’t seem to show in in iTunes, but just the OSX finder and Wavelab MetaData view in audio file edit mode.

Double click in the Meta Data window, erase the fields you don’t want to see, then save the audio file.

Ok, that seems like an easy temporary fix, but is there any way to keep WL from adding any info even when I keep it blank in the montage?


If this data is added automatically when saving a file, that means it has been set “as default”.
To change this, open the Meta Data editor, clear it, and press the button “Use these settings when creating Audio File files”.

Yep, that was it. I didn’t realize that it was using a default even when it was left blank.

Thanks for the clarification.