Metagrid and Cubase?

Just got Metagrid and I have some problems:
On my PC, Metagrid is working except for Keyboard Shortcuts, Text and Pause. Nothing happens. I don’t know if it is Metagrid not sending or Cubase not receiving.

On my Mac, Metaserver is not starting. Tried to run it in terminal mode and got the following result:
“ThomasSssonsMBP:~ thomas_svensson$ /Applications/ ; exit;
Fatal error: Unexpectedly found nil while unwrapping an Optional value
Illegal instruction: 4
Saving session…
…copying shared history…
…saving history…truncating history files…
[Process completed]”

I have mailed Metasystem, but no reply yet.

Anyone with similar experience or maybe solutions?

My spec below.

Thank you in advance.

My perspective is from Windows 7 You may wish to look up the facebook group if you want a quick reply this weekend.

If Metagrid is working except for keyboard shortcuts, well that is a huge thing. So you are implying app specific commands are working fine, but not keyboard shortcuts? There is an app specific command for every key command in Cubase, so you don’t need to use keyboard shortcuts, but it’s understandable if you desire that.

Does your port set-up under Metasystem MIDI show metasystem loop MIDI port? Does Cubase show Cubase Meta loop MIDI port?
Loop MIDI show metasystem loop midi port and cubase meta loop midi port?
If you don’t get a reply, maybe give a step-by-step on how you are programming keyboard shortcuts?

If no luck maybe post screen shots of Cubase Gereric remotes 1, and 2. Generic remote 3 if you have added any.

Thank you for taking time and answer.
I’ve looked at the FB-group but there is very little activity. Saw that someone asked about simular problems quite a while ago and the answer was to contact the via mail.
App specific commands work well for C 9.5 commands, but unfortunately there are som changes in C 10 that makes some of the commands to not work. I am in progress of examine the differences and I think I can fix that in the Generic Remote files.
The port-setup is exactly as in the tutorial videos and the manual.
Since I just bough Metagrid I am for the moment experiments in order to start building my own grid.

As for the Macbook problem, I suspect it is a incompability issue even if the requirements says OSX 10.7 or later. I hope Metasystem will reply to my mails.


Metagrid has not been updated to reflect the new features i.e. new key commands of C10. The Metagrid app specific commands are from C9.5. For now, you would have to make your own key commands in Metagrid without using Metagrids App Specific Commands.

What changes in C10 make some of the commands to not work? Can you list some examples?

You can use the App Specific Commands for the new C10 commands too. If you have Metagrid setup to use a 3rd Generic Remote for Macros you are not restricted to using it only for Macros. In addition to Macros you can use it to execute LE & PLE Presets and any Cubase Command. Generally there is no reason to use it to execute Cubase Commands since those are already taken care of. But if it is a new Command that isn’t included in the 9.5 list then you can add it to Generic Remote 3 as a faux-macro.

One reason to avoid using Metagrid to send Cubase Key Commands (e.g. ctrl+w, etc.) is because in Metagrid you need to use Keyboard Shortcuts to generate the key-stroke. While there is nothing wrong with this, Keyboard Shortcuts will only execute if Metagrid is not locked to a specific app. Personally I like to lock Metagrid to Cubase so it doesn’t switch to a different apps when I shift the Windows focus to read a PDF or check something on the web. Can’t do that if you have buttons that use Keyboard Shortcuts.

Thank you rodger for the input. I’m aware of the “workarounds” but since I just got Metagrid I am in the process of trying to learn and understand the possibilities and restrictions. Maybe I never will be using Keyboard commands, but as it is now I can’t evaluate that. I don’t have it locket to Cubase so that can’t be the cause.
Meta system has responded, so hopefully they can help me with a solution both on this and my Mac problem.
I have also gone through the differences between 9.5 and 10 so I can correct the settings in Generic remote to handle these until there is an update in Metagrid.
However, I have noticed that Metagrid sometimes crashes when I choose an app-specific command.

Oops yes. My apologies!

Using the 3rd Generic Remote, you can do that as long as the Cubase Command exists. What I meant to imply is that the new key commands for the new features in C10 are not available as app specific commands because those are based on C9.5.

While it really isn’t an App Specific Command, within Metagrid when setting up Action Sequences Cubase User Macros are still accessed under App Specific Commands. Metagrid just thinks “Macro 1” is a real Cubase command or at least it treats it like it is.

Yes. For Cubase macros, LE commands etc.

I was trying to point out to the OP regarding some new Cubase 10.0 features, Metagrid app specific commands don’t exist in the list. For example to open “add track selector.” That key command is listed under Add Track in Cubase key commands, but it is not listed in the Metagrid App Specific Commands because it hasn’t been updated yet. It’s still based on the C9.5 version.

Therefore to use the Add Track in Metagrid you would either have to use the keyboard shortcut, or inside app specific commands go to Metagrid: User Macros, then use Cubase Generic Remote 3.

A never ending story :smiley:

Apologies for a long post in advance :blush: .

Now I have gone through the differences between 9.5 and 10 and it takes a little different solutions to handle these in the current version of Metagrid:

  • Commands found in both versions, but changed in 10: (example: File / Key Commands are now Edit / Key Commands):
    You can still use App specific commands in Metagrid but you need to change the Metagrid file containing the corresponding command. In the above example, it is the entry with Control Name 349, change File/Key Commands to Edit/Key Commands.
    I have found 3 such commands.

  • Commands that are new in 10:
    I have solved this by creating a new file Metagrid_Cubase10.xml containing these commands. I have used cc16 since this is not used before.
    In Metagrid I create an action queue with a MIDI message that corresponds to what I put in the xml file.
    I have found about 40 such commands. I can send you the list and/or the xml-file if you want.
    For this to work, Midi input must be set to Metagrid-in instead of Cubase-in for some reason!

  • Commands found in 9.5 but missing in 10:
    Not relevant for me.

Unfortunately, I have not yet been able to send Keyboard shortcuts from the Action Queue, nothing happens in Cubase. For example, I would want to be able to send Enter or Escape with a Metagrid button. Does this work for you?