Metaserver not launching at startup

Ever since my fairly recent DAW upgrade to Win10, I’ve had a problem where Metagrid’s Metaserver is not launching at startup like it should (and did before the upgrade). I can launch it just fine manually. After doing that if I right click on the icon in the System Tray, the option “Start with Windows” is checked. Similarly in Task Manager’s Startup tab it is set to enabled. So it should launch at startup.

I’ve tried running it both as Administrator and in compatibility mode. Neither helped.

This is how Metaserver worked for me too. After start-up, desktop open, I would have to click on the icon. What’s strange is a couple months ago I did this, but noticed in the task bar, lower right that it was now opening upon start up therefor I had 2 Metaserver icons in the task bar. From that time on, I no longer had to click on the desktop icon. I checked “start with Windows” and it worked as intended for the past couple months.

But this week I have transferred to a new PC and I’m back to the old behavior like you experience. If you get a solution, please let me know.

I figured out how to use Task Scheduler to start up MetaServer. It took awhile to get the settings right, for awhile it launched but didn’t create an icon in the system tray so you couldn’t change its settings. So the iPad would find the server but the server couldn’t talk to anything :confused:

The attached gif shows the settings that work. Start with plain “Create Task” (with the basic one you’d need to make further edits later, so its easier not to use it to start). Use the settings shown. Change the path in the Actions section to match what you have


If after creating a task you need to edit it, find it like in the gif. BUT (this isn’t in the gif) then douple click the task. After that you can select Properties and that lets you edit the task.

Finding existing tasks is tricky since there doesn’t seem to be a search capability. AND while it seems the list is in alpha order it is really a couple of lists each in their own alpha order.