Meters in mixer slow/low FPS/not fluent


Title pretty much says it all. My meters seem slow/jittery in their movements or in other words: they look like they’re operating at a very low FPS.

It’s not like they’re not giving the right values, it’s just that for some reason I find fluidly moving meters much easyer to read.

Anyone ever noticed this, and is there a way to remedy this? A fader FPS setting or something?

I would expect this might happen when the system is heavily bogged down by processes, but Audio performance is at a steady 25%, so I’m confident it’s not performance related.


I would like to add that, I’ve been noticing this for quite a while now, and I have no idea if it’s related to an update, or anything ‘new’ in my system, or if maybe it has allways been like this, I just simply failed to notice before.

If this last thing is the case, I guess you could call this a feature request - Highten meter refresh rates.

I saw that on my old computer and it was definitely a problem with how much I loaded it. Not so much the amount of tracks or the processing on those tracks but rather what I had going on in terms of metering in general. If I pulled up 2-3 instances of Izotope Insight and maybe one of their plugins - with 1 or more of them having a spectrogram view or even just the spectrum view the meters would get choppy. On that computer I would have to close windows with those items on them and then maybe even have to either wait a bit or reload the project.

With my new computer no such problems yet.

So I would investigate which plugins you have open and what type of ‘processing’ they do to show metering, and then maybe look into graphics settings (?)…

Hi Mattias,

Thanks for your reply! See this is where it gets iffy, because of course performance was my first guess! Thing is, I’m working on a dedicated, custom built DAW system that’s not very old yet, and I didn’t pick the budget option either. So apart from a very thought out hardware plan, it’s got some tweaks under the hood as well. Not to boast, but to give you an idea of it’s performance; when it comes to running plugins, or instruments I have yet to meet a colleague even close to what I’m able to run at ridiculously low sample rates, virtually latency free, and the meters run far from smooth in even a simple 1 stereo channel project.

Second thing - graphics settings. First thing I checked was my monitors refresh rate, and it’s set to 59.something hz, zo that can’t be it. Then - as I’ve had problems with plugin GUI’s in the past - I checked windows’ scaling settings and they’re nicely set to 100%. The only thing I haven’t done is update my graphics drivers to nVidia’s latest, however I don’t think it’s a lot more then 3 months ago I did that, not to mention I keep my Windows updates on, and as far as I know they come with nVidia drivers. Might not me the latest but they’re usually not that far behind.

Any ideas about graphics settings in particular worth checking?

I’d have to sit down and take a look, it’s been a while since I set it up.

But have you noticed a difference when having the types of displays I talked about open?

Would it be possible to make a short recording of this? That would be very helpful.
Do you have a second graphics card in your computer? (For example an integrated graphics card from Intel?)

Sorry for this late reply, it’s been a bit hectic lately.

I’ve run a few random tests, but I’ll see about doing some more. It seems meters (or GUI) across the board are unstable.

I’m running my monitors off of the nVidia card (1080 Ti if I’m not mistaken), and I have a separate Blackmagic Decklink Mini for video, running to a TV through HDMI.

I’m pretty sure 99% of modern motherboards come equipped with some form of on-board intel video chipset, but I’m not using that, or ever have.

Also, I could do a recording, but I’m not sure if the recording process itself wouldn’t interfere with whatever the situation is. I mean, I guess I could try tho! But if it’s just for the purpose of trying to see what’s going on: The meters have a very low refresh rate, which makes them very hard to read because they don’t move smoothly. It also doesn’t seem to react to any hightening or lowering of CPU load. Not sure what else to tell you :person_shrugging:

What computer components do you have, and did anything change before this started to happen (i.e. different hardware or software updates)?

Device name Heron Music DAW
Processor Intel(R) Core™ i9-9900K CPU @ 3.60GHz 3.60 GHz
Installed RAM 128 GB
Audio Interface RME HDSPe AIO
Video nVidia RTX 1080 Ti
Video TV output Blackmagic Decklink Mini Monitor
System HDD Samsung 970 pro 500GB
Projects/Samples HDD Samsung PM1725a HHHL 6,4TB
System type 64-bit operating system, x64-based processor
Edition Windows 10 Pro
Version 21H2
Installed on ‎9-‎2-‎2021
OS build 19044.2251
Experience Windows Feature Experience Pack 120.2212.4180.0

If you need any more info, or more specifics, please let me know.

Like I said in my original post, it’s been like this for a while and I’m unsure of the exact start of it. I do regularly update drivers and my OS, so it’s possible something’s slipped in however I’d think it would be a known issue if it had in any recent Windows update.

I suppose it could be your Nvidia card being a bottleneck… but… not sure if that’s how it’d manifest itself.

Only other thing I can think of is that your CPU isn’t able to keep up. I know you said your audio performance meter is at 25%, but if that meter is specifically for audio then it’s possible calculating metering can still ‘lag’. I know it was a really good CPU at the time, but it is four years old by now.

I had a Ryzen 1700, 8-core CPU which was one year older than yours and it had all cores locked at 3.6GHz I think. It too ended up with sluggish meters under the circumstances I mentioned - meaning with spectrum display on some plugins. Audio was uninterrupted and the audio meter was under 100%. With my current Ryzen 5900 12-core CPU I’m at about 25% audio meter load but with a bunch of meters running at the same time with no lag.

So CPU would be my guess. I could be wrong of course and I’m not sure how you could test this.

Try disabling NVIDIA, use onboard graphics and see how it goes just to know where the problem is, not suggesting this as a solution but a test.

just checking - you’re not referring to meter decay rate are you ?

there’s a ‘fallback’ setting in preferences ?

No, that’s all fine! :slight_smile:

Nah the 1080 is old, but it’s super fast. I don’t think it would cripple on Nuendo/Windows, and the CPU is far from fully loaded. Both the VST monitor as well as system resources monitor show it has plenty of overhead.

I’ll check this out and see what happens!

Thanks for all the help so far guys!

The part you quoted is me talking about the CPU, not GPU. Some users have in the past had problems with Nvidia cards/drivers, but since I have AMD cards I wouldn’t know how or why that would be an issue (and those issues were dropouts I believe, not visual problems).

As for the CPU what I also mentioned was that when I had problems with meters the CPU didn’t max out in the audio performance meter (nor task manager meter). So if the meters measure either max load or max audio path load then it’s entirely possible for you have have problems without those meters peaking.

I think you might be surprised by just how much these latest generations of CPUs can be faster than the one you have.

Either way, I don’t have any other things to try out or think about so best of luck. Report back once you figure out the problem.