Metronome on playback

I am sure I am missing something, but in 3.5 (and earlier), if I play back a score, the metronome mark/speed is lit up and visible. In 4.0, it’s greyed out, and only appears when playback it stopped. Is there a setting I need to activate?

No, you should be able to toggle the click button in the mini Transport during playback in Dorico 4, just as you could in 3.5 – it’s working as expected for me.


Two screenshots of the mini-Transport bar: the greyed out is while playing. I must be missing something very obvious, but nothing I click changes this.
Screen Shot 2022-01-17 at 1.50.33 PM
Playing back:
Screen Shot 2022-01-17 at 1.50.22 PM

We’re talking about the same button? The little metronome shaped doodad to the left of the fixed tempo button? It’s not disabled during playback, merely not activated or switched on. Here it is, during playback, not disabled but not active:

(replete with annoying tooltip, sorry about that) and here it is during playback, now active:

I think I was not clear enough: it is the metronome speed/rate - the number on the far right of the transport. In 3.5, it stays lit, showing the metronome mark; in 4.0, it is greyed out during playback. The images I attached with it stopped (lit), and playing (grey). The metronome click does work - it’s the visual on the right that is the issue.

This is not a big deal, and I probably wouldn’t have caught it had I not been looking to see the rate of rallentando that was taking place. But I was curious about what had changed.


Right, thanks, Ron, now I know what you’re referring to. We disable it during playback to make clear that you can’t change it, but I agree that it’s a bit unfortunate inasmuch as it makes it harder to read during playback. I’ll have a think about it.

Ah, ok!

Not a big deal - there are other, larger things for you think about, I’m sure.

Thanks for clearing this up.

A related question to this metronome setting… I have the impression that my composition uses the tempo shown in the above mentioned metronome tempo shown at the top right and is not reacting to changes in Q values I specified in the score.

The piece starts at Presto Q=296 which is rounded in the metronome tempo indication to 300. The first part with repetitions is correctly played. Subsequently the tempo changes to Q=230 but it continues in 300.

Only when I click on the note next to the metronome tempo, it becomes blue and the value at the top right changes to the correct tempo 230. I don’t think that is the point of a tempo mark. It should change automatically.

I attached the tempo change which is after the final 4 bars of a repeat.

I did another test. When I have adjusted to the correct tempo for the second slow part by clicking on the note next to the tempo indicator, as mentioned above, and go back to bar 150 (clicking on the first note and pressing P,. playback starts correctly at 300 and changes automatically to 230 in bar 153 but when I go back to the start of the piece and get back to bar 153 playback just continues at 300.

If the note is not blue then you are in fixed tempo mode and all notated tempo changes will be ignored.

It would be easiest to diagnose this issue if you attach your project here. Perhaps just export a single layout from the project containing just one instrument, and attach that here.

Thanks both, Janus had the solution. Somehow the note button setting fixed tempo, which I actually never used on purpose and was not monitoring, was off. Probably due to pressing a wrong shortcut What I thought as rounding q=296 to fixed tempo 300 was just a coincidence.