Metronome Precount not working

I’ve got the metronome setup to pre-count for both record and play. The metronome sound itself is working properly – it is audible. It’s just not pre-counting the measure in.

I googled it and read something about Pre-roll and turning that on or off would affect the metronome’s pre-count. I can’t find a place to turn Pre-roll on or off. It looks like it should be below the left and right locator fields in the Toolbar. But I don’t see it.

Anyone know how to get the Metronome pre-count working?

Thanks,
Mahlon

You can easily turn it on & off precount:
Precount on & off.jpg
You can also check metronome setup:
Metronome 1.jpg
Metronome 2.jpg
P.S. My Cubase it is in Portuguese, but you just need to find the similar place to setup your metronome

Can you send screenshot of your Metronom Setup, please?

There is no metronom pre-count for playback, there is for record only.

See my pictures above

Thanks for the help and the pictures. I did find the pre-roll buttons on the transport bar and understand that part now.

But about the metronome pre-count, as far as I can tell I’ve got everything set up correctly so that the metronome should count in 1 measure before recording. Pre-count is definitely turned on. But still, there is no count in.

I will post a pic of the metronome setup tonight when I get home.

Thanks again for the help.
Mahlon

p.s. I didn’t realize there was not a count-in for Play only. I wonder why Steinberg wouldn’t include that feature in an otherwise incredibly, densely featured program.

I’m running into this problem in Cubase 7.5. It seems like the metronome is set up correctly, but precount is not working for me, even when it’s enabled. I haven’t found an answer yet.

Hi,

[To Mahlon]: Could you switch your Cubase in to the English language, and send the screenshot again? Unfortunately, I don’t understand this localization. I would like to be 100% sure, your settings is OK.

[To peterNH]: what exactly is your problem, please? Can you see the pre-count in the Transport bar (time display)? Can you see, the cursor jumps 1 bar backward? Is your problem visible, or audible only? Are you using Audio click (sound, or beep), or MIDI (how is it routed)?

peterNH - Let’s skip to the chase. Move the curser to the beginning on the project. Arm a track for record, hit RECORD. If you have the metronome set for a precount of one bar, you will hear four beeps (4/4 time) and then the recording will begin as the curser begins to move.

What do you have there? If the recording starts immediately, you have not setup the precount.

I realize it’s been a year since I posted my original issue, but just for the record, I still can’t get pre-count to work correctly. I’m now in Cubase 7.5 and I can get it to work with MIDI sounds, but not with the Beep setting. I understand all the features, but I’m getting no click sound when I try to use the built-in beeps. Very weird and annoying, but still there. Just wondering if other folks have seen this or it’s just me.

And to answer the question from mr.roos (albeit a year later), the recording and playback begins immediately when pre-count is selected in the menu and on the settings menu, and the icon is enabled in the Transport panel.

So, good point, their is no visible evidence that Cubase is trying to do any precound whatsovever, which tells me it’s not a problem with the sounds, but with pre-count being enabled at all. Thanks.

Okay, I take that back. On playback, there’s no delay. On Record, it does pause the indicated beats before starting to record.

Found the problem. Here’s the fix:

  1. Go to Devices > VST Connections.
  2. On the Outputs tab, click in the “Click” column of the first row to enable Click for the selected audio device.

Sigh. Not exactly intuitive, but it solved the problem. Metronome works fine now.

Oh, yes, you do have to enable the click in your output section… Sorry, I just assumed you had done this.

Found a solution that worked for me!
I hope I helped.
precount issue.PNG