Metronome sound when recording pre-roll

If you select 1 measure of pre-roll and press the record button, there will be no metronome sound during the pre-roll section.
Session men come and say they are surprised when recording, or the feeling is broken when the metronome suddenly comes in during the recording section.

Hi and welcome to the forum,

Enable the Click during Count-in option in the Transport > Metronome Setup > Click Options, please.

When you click, only one of the prerolls or count-in works.
In other programs, the two options work together to make recording your actual performance easier, but only Cubase works this way. Is there another way?

Hi Sang-wook,

Maybe I can help you with a few remarks:

There are many situations when recording, but in this context I see only three:

Cas A, case B and case C.

Let us assume that you want to start a recording at bar 6.

Case A
Nothing was recorded between bar 1 and bar 6.

Procedure:

  1. Set locator 1 at bar 6
  2. Activate count-in for 1, 2, 3, 4, 5 or 6 bars
  3. Start record

Note: No pre-roll needed

Case B
Something has been recorded between bar 1 and bar 6 AND
the musicians need to hear it in order to get
… the mood
… the pitch
… the tempo.

Procedure:

  1. Set locator 1 at bar 6
  2. Activate pre-roll for 1 or more bars
  3. Start record

Case C
Something has been recorded between bar 1 and bar 6 AND
it contains NO clear tempo information (just a pad, for instance)

  1. Prepare an audio click track to help the musicians with the tempo:
    1.1 Set the locators at bar 1 and bar 6
    1.2 In the top menu select Project → Signature Track → Render Audio Click between Locators
    1.3 You see the short click track and make sure it is not muted
  2. Now continue the preparation as in Case B

Note: no pre-roll needed.

Hope This Helps.
Good luck.
Karel