Microphone issues with Cubase 11 Elements Argh - can anyone help please?!

Hi all. Recently switched to SE Electronics Neom USB Mic which worked fine at first, could record vox into Cubase 11 no problems. Suddenly all sound is distorted when I try to record vox, even with mic gain button low. It’s not the mic as the issue doesn’t happen with other software, and the company replaced it to rule a broken diaphragm out anyway. Anyone else had this and any ideas what to do please? Built-in interface so I don’t have one…thinking of getting one though. Thanks in advance, much appreciated!

Without your OS info it’s not possible to asnwer, except by giving all possible answers in perpetuity throughout the universe. :upside_down_face:

Add your info here: https://forums.steinberg.net/u/hybridvoodoo/preferences/profile

Oops sorry! Windows 11 64 bit. Does that help? Have reinstalled mic driver and Cubase but no joy as yet. Thanks! :blush:

Did you try all USB ports on your machine?

Hi, yes I have tried other USB ports but the issue is still the same! :tired_face: